amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > SAM 460 SATA Fragen... [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 -2- [ - Beitrag schreiben - ]

19.04.2013, 12:47 Uhr

tploetz
Posts: 4026
Nutzer
Hallo, warum werden vom SATA-Controller Sil3114 von U-Boot nur zwei Geräte angezeigt, es sind aber drei angeschlossen.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

20.04.2013, 12:35 Uhr

Stanglnator
Posts: 179
Nutzer
Maxbus vom Sii3114 auf 2 beschränkt.
Bei mehr als 2 gerten setz den Maxbus auf 3 bzw 4 für alle 4 Ports.


--
Mir nach! Ich folge Euch!

[ - Antworten - Zitieren - Direktlink - ]

20.04.2013, 12:50 Uhr

tploetz
Posts: 4026
Nutzer
@Stanglnator:
wo finde ich den maxbus, bei U-Boot ist der Befehl unbekannt.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

20.04.2013, 13:37 Uhr

DaFreak
Posts: 251
Nutzer
@tploetz:
sii3114ide_maxbus 2

(2 channels * 2 = 4 geräte)

http://www.titan.co.nz/amigaak/AA020816.htm
--
Sam440ep + AmigaOS4.1 im Morex 3677 Gehäuse

[ - Antworten - Zitieren - Direktlink - ]

20.04.2013, 15:43 Uhr

tploetz
Posts: 4026
Nutzer
@DaFreak:
sii3114ide_maxbus 4 ist bei U-Booot unknown command.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

20.04.2013, 16:38 Uhr

Dr_Dom
Posts: 655
Nutzer
Den Befehl gibt es ja auch nicht, wo hast du den her?
--
wenn dein Rechner defekt ist, funktioniert der Ersatzrechner erst recht nicht

Murphy


[ - Antworten - Zitieren - Direktlink - ]

20.04.2013, 16:47 Uhr

Palgucker
Posts: 1341
Nutzer
So wie ich das nach 15 Sekunden "kugeln" mitbekommen habe, ist sii3114ide_maxbus eine ENV-Variable?
Wohl mit

nvsetvar sii3114ide_maxbus=2

zu setzen.

Gruß Palgucker

[ - Antworten - Zitieren - Direktlink - ]

20.04.2013, 16:49 Uhr

Dr_Dom
Posts: 655
Nutzer
Nicht mal Googeln, DaFreak war so nett und hat auch gleich den passenden Link mit reingesetzt, Lesen muss der Fragensteller schon selbst! ;-)
--
wenn dein Rechner defekt ist, funktioniert der Ersatzrechner erst recht nicht

Murphy


[ - Antworten - Zitieren - Direktlink - ]

20.04.2013, 17:30 Uhr

tploetz
Posts: 4026
Nutzer
Zitat:
Original von Palgucker:
So wie ich das nach 15 Sekunden "kugeln" mitbekommen habe, ist sii3114ide_maxbus eine ENV-Variable?
Wohl mit

nvsetvar sii3114ide_maxbus=2

zu setzen.

Gruß Palgucker


nvsetvar gibt es nicht.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

20.04.2013, 17:51 Uhr

angel77
Posts: 832
Nutzer
Eventuell würde es helfen den betreffenden Link auch sinnvoll zu kennzeichnen, so dass der geneigte Leser weiß was ihn erwartet ...

Könnte die Klickwahrscheinlichkeit Unwissender in beträchtlichem Ausmaß erhöhen. Gerade in Zeiten in denen sich Mancher mehrmals überlegt worauf er alles klickt, z. Bsp. aus Sicherheitsgründen oder wegen existierender Bandbreitenlimitierungen, etc. ...

:D

vlg,

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

[ - Antworten - Zitieren - Direktlink - ]

20.04.2013, 19:45 Uhr

tploetz
Posts: 4026
Nutzer
@angel77:
welchen Befehl soll ich vor "sii3114ide_maxbus" setzen? Mit setenv und saveenv
klappt es nicht.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

21.04.2013, 13:54 Uhr

DaFreak
Posts: 251
Nutzer
@tploetz:
hmmm, mit setenv & saveenv klappt es nicht?
Environment Variables code:
setenv sii3114ide_maxbus 2
saveenv




du kannst ja mal nachm Starten vom OS in die CLI eintippen:
NVGetVar >RAM:varlist

und anschließend die textdatei "varlist" hier reinposten. da müsste doch was mit maxbus drin stehen.
--
Sam440ep + AmigaOS4.1 im Morex 3677 Gehäuse

[ - Antworten - Zitieren - Direktlink - ]

21.04.2013, 14:08 Uhr

tploetz
Posts: 4026
Nutzer
@DaFreak:
hier die varlist

baudrate=115200
loads_echo=1
hostname=Sam460ex
stdout=vga
stdin=usbkbd
ide_doreset=on
ide_reset_timeout=15
ide_cd_timeout=20
pcie_mode=RP:RP
pciconfighost=1
bootcmd=menu; run menuboot_cmd
menucmd=menu
boot_method=boota
usb_enable_4x0=1
usb_retry=1
usb_ohci_power_down_before_reset=1
scan_usb_storage=1
ethact=ppc_4xx_eth0
ethaddr=00:50:c2:80:d5:06
ipaddr=192.168.3.134
serverip=192.168.3.80
video_activate=pci
hush=0
serdes=pci-e
boot1=s4sii
boot2=s4siicdrom
boot3=usb
boota_timeout=2
menuboot_delay=2
os4_commandline=debuglevel=2
bootargs=root=/dev/sda3 console=tty0
ver=U-Boot 2010.06.05 (Apr 14 2011 - 10:54:55)
sii3114ide_maxbus=2
menuboot_cmd=boota

tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

21.04.2013, 14:19 Uhr

Palgucker
Posts: 1341
Nutzer
@tploetz:

So wie ich das lese, sollten die Befehle printenv, setenv und saveenv von der Uboot-Shell aus eingegeben werden.

erst mal schauen, was der aktuelle Wert ist..

printenv sii3114ide_maxbus

Wenn der Wert nicht 2 ist, mit..

setenv sii3114ide_maxbus=2

setzen und mit

saveenv

abspeichern.

Der Befehl nvsetvar sollte eigentlich in C: liegen, den wirst du doch nicht verbasselt haben. :D

Gruß Palgucker

[ Dieser Beitrag wurde von Palgucker am 21.04.2013 um 15:42 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

21.04.2013, 14:53 Uhr

tploetz
Posts: 4026
Nutzer
@Palgucker:
mit printenv und saveenv geht das auch nicht, bei U-Boot steht not available.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 21.04.2013 um 14:53 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

21.04.2013, 21:26 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
habe den Wert für UDMA auf G gesetzt mit folgerden Befehl
setenv sii3114ide_xfer G
saveenv
Geht damit das Kopieren schneller?
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

03.07.2013, 20:41 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
der USB-Stack vom SAM 460ex taugt überhaupt nichts, bringt nur Ärger,
mal geht die Maus nicht, andermal die Tastatatur nicht und gelegentlich geht
gar kein USB.
Sowas kenne ich vom Amiga 4000T mit Poseidon nicht, das funktionierte immer.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

03.07.2013, 21:18 Uhr

inq
Posts: 445
Nutzer
@tploetz:
das liegt aber nicht am SATA Controller, oder?

inq

[ - Antworten - Zitieren - Direktlink - ]

03.07.2013, 21:37 Uhr

tploetz
Posts: 4026
Nutzer
@inq:
Am SATA-Controller liegt es nicht, oder soll ich einen neuen Thread aufmachen?
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 03.07.2013 um 21:38 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

04.07.2013, 21:49 Uhr

tploetz
Posts: 4026
Nutzer
Hallo,
habe beim SAM 460ex ein SATA-Kabel am Controller angeschlossen, was ich nach draussen verlegt habe und an eine externe SATA-Festplatte angeschlossen habe.
Damit geht das Sichern von Daten sehr schnell.
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 04.07.2013 um 21:51 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

09.07.2013, 19:09 Uhr

inq
Posts: 445
Nutzer
Zitat:
Original von tploetz:
Hallo,
habe beim SAM 460ex ein SATA-Kabel am Controller angeschlossen, was ich nach draussen verlegt habe und an eine externe SATA-Festplatte angeschlossen habe.
Damit geht das Sichern von Daten sehr schnell.


Hast du das direkt angeschlossen oder mit Adapter auf eSATA? Wie hast du die Stromversorgung angeschlossen?

Gruß
inq
--
Config:
A1200/30/50/FPU/SCSI/64MB, WinUAE/40/xx/xxMB, EUAE/40/25/xxMB, CDTV, CD32/SX32MK2/HD - AOS3.5

[ - Antworten - Zitieren - Direktlink - ]

09.07.2013, 20:49 Uhr

tploetz
Posts: 4026
Nutzer
@inq:
Habe das Sata-Kabel direkt am 3114 Controller angeschlossen, die externe
Festplatte wird mit Netzteil betrieben.
Einen Adapter verwende ich nicht, die Festplatte hat USB- und eSata-Anschluss,
die Festplatte hat eine Größe von 1 TB und ist mit SFS2 formatiert.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

09.07.2013, 22:40 Uhr

inq
Posts: 445
Nutzer
Zitat:
Original von tploetz:
@inq:
Habe das Sata-Kabel direkt am 3114 Controller angeschlossen, die externe
Festplatte wird mit Netzteil betrieben.
Einen Adapter verwende ich nicht, die Festplatte hat USB- und eSata-Anschluss,


Ok. Also hast du ein Kabel SATA(intern)->eSATA(extern) verwendet? Quasi ein Adapter-Kabel.

Kann man das externe Laufwerk während des Betriebs abstecken? Oder nimmt das einem die Workbench übel? (Bitte NICHT probieren, wenn du's nicht weißt!).

Gruß
inq

--
Config:
A1200/30/50/FPU/SCSI/64MB, WinUAE/40/xx/xxMB, EUAE/40/25/xxMB, CDTV, CD32/SX32MK2/HD - AOS3.5

[ - Antworten - Zitieren - Direktlink - ]

09.07.2013, 22:44 Uhr

tploetz
Posts: 4026
Nutzer
@inq:
Das Kabel kann man während des Betriebes rein -und rausziehen, die Festplatte
wird aber erst nach einem Warmstart erkannt.
tploetz :boing:

[ - Antworten - Zitieren - Direktlink - ]

09.07.2013, 22:46 Uhr

inq
Posts: 445
Nutzer
@tploetz:
Danke! :)

[ - Antworten - Zitieren - Direktlink - ]

09.07.2013, 23:06 Uhr

tploetz
Posts: 4026
Nutzer
@inq:
Ich hab das so gemacht, weil SATA schneller ist als USB.
Edit:
Es ist kein Adapterkabel, nur ein SATA-Kabel, Die Festplatte hat als Eingang eSATA
tploetz :boing:

[ Dieser Beitrag wurde von tploetz am 09.07.2013 um 23:21 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]


1 -2- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > SAM 460 SATA Fragen... [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.