amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > AROS und Amiga-Emulatoren > WinUAE 2.9.0 und PPC [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- 2 [ - Beitrag schreiben - ]

08.10.2014, 11:31 Uhr

Pfau_thomas
Posts: 71
Nutzer
Wer hat die neue WinUAE Version schon mal ausgetestet und wie gut ist die Power PC Emulation geworden.Da müßte ja dann das Amiga OS 4.x laufen usw.

[ - Antworten - Zitieren - Direktlink - ]

08.10.2014, 13:19 Uhr

ciVic
Posts: 129
Nutzer
Ja es läuft wohl:

http://amigafun.wordpress.com/2014/08/19/installing-amigaos4-1-classic-onto-winuae-2-9-0beta12/

Jetzt wo ich das sehe habe ich Lust bekommen es mal zu probieren, hätte ein passendes OS 4.1 Classic sogar da.
--
ciVic

A4000D - CSPPC 060/50 604e/200 - Piccolo SD 64 - 40 GB IDE - CD-ROM - 146 MB RAM - X-Surf 2 - A2320

[ - Antworten - Zitieren - Direktlink - ]

08.10.2014, 18:41 Uhr

Wolfman
Posts: 3664
Nutzer
Muss ich doch direkt mal suchen, welche PPC-Soft ich aus meiner aktiven Amigazeit (zuletzt A 4000 T mit CSPPC)noch habe ;)
--
God forgives - who forgives God ?

[ - Antworten - Zitieren - Direktlink - ]

09.10.2014, 12:39 Uhr

analogkid
Posts: 2383
Nutzer
Zitat:
Original von Wolfman:
Muss ich doch direkt mal suchen, welche PPC-Soft ich aus meiner aktiven Amigazeit (zuletzt A 4000 T mit CSPPC)noch habe ;)
--
God forgives - who forgives God ?


PPC-Software, die Warp3D benötigt, läuft allerdings nicht (bzw. nur im Software-Renderer).

[ - Antworten - Zitieren - Direktlink - ]

09.10.2014, 15:00 Uhr

Pfau_thomas
Posts: 71
Nutzer
@analogkid:
Wenn ich mich daran erinnere,
Warp 3d Hat doch was mit der Grafigkarte etwas zu tun es ist doch etwas bevor es etwa OpenGL gab.Und diese läuft auch ohne PPC.

[ - Antworten - Zitieren - Direktlink - ]

09.10.2014, 15:47 Uhr

analogkid
Posts: 2383
Nutzer
Zitat:
Original von Pfau_thomas:
Wenn ich mich daran erinnere,
Warp 3d Hat doch was mit der Grafigkarte etwas zu tun es ist doch etwas bevor es etwa OpenGL gab.Und diese läuft auch ohne PPC.


Es gibt für WinUAE mit Wazp3D im Aminet etwas, womit Warp3D-Funktionen auf Direct3D-Funktionen unter Windows nachgebildet werden, d.h. 68k-Apps können auf HW-Beschleunigung mit Warp3D zurückgreifen. Nun gibt es Wazp3D als HW-Beschleuniger(!) nur für 68k, für PPC höchstens als SW-Renderer.

[ - Antworten - Zitieren - Direktlink - ]

09.10.2014, 16:38 Uhr

Wolfman
Posts: 3664
Nutzer
Ich hatte seinerzeit eh "nur" eine PicassoIV und keine CVPPC ;)
--
God forgives - who forgives God ?

[ - Antworten - Zitieren - Direktlink - ]

09.10.2014, 21:03 Uhr

huepper
Posts: 481
Nutzer
Wazp3D funktioniert aber leider nur mit uaegfx, das widerum nicht mit der PPC Emulation unter OS4.
Wie das unter OS3.9 aussieht, kann ich gerade nicht beantworten.
--
Signatur ? hmm wo hab ich sie nur wieder ?

[ - Antworten - Zitieren - Direktlink - ]

10.10.2014, 18:33 Uhr

wawa
Posts: 314
Nutzer
@huepper:
für gewöhnlich funktioniert wazp unter uae, und das unter amiga systemen als auch unter aros. würde mich wundern wenn sich da was geändert hätte was die 68k seite anbetrifft. im übrigen kann man unter uae wazp komplett auf der amiga seite in software laufen lassen oder windows hardware beschleunigung verwenden, aber das weisst du sicher.
warpup apps benötigen jedoch eine ppc versionen von warp3 bibliotheken, und dies liegt wazp nicht bei, war auch nie so richtig das thema. unter os4 sollten eigentlich entsprechende wazp bibliotheken verwendbar sein auch unter uae. ich wüsste nicht wieso nicht. sonst mail alain mal an.

edit: äh. merke grad dass ich nicht weissob wazp unter graka emulation geht. müsste aber schon glaube ich. ich hatte s mal auf echten hw testweise.

[ Dieser Beitrag wurde von wawa am 10.10.2014 um 18:35 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

10.10.2014, 18:42 Uhr

Pfau_thomas
Posts: 71
Nutzer
@huepper:
Sehe ich es richtig?
Uaegfx brauche ich eigentlich für die Grafikdarstellung meinetwegen
1024x768 und 24Bit Farben Darstellung auf der Workbench oder so und simuliert im Prinzip eine Grafigkarte.Das hat aber nichts mit PPC zu tun, OS 3.9 z.B läuft da dann auch unter der 24Bit Farbdarstellung.
Funktioniert aber nicht bei Anwendungen die nur eine PAL oder HAM Bildschirm Farbdarstellung nutzen können z.B. DPaint III -V usw.

[ - Antworten - Zitieren - Direktlink - ]

11.10.2014, 01:06 Uhr

angel77
Posts: 832
Nutzer
Wenn ich dich richtig verstehe, dann vermutest du richtig.

Und wenn du einen komfortabel eingerichteten Desktop unter Win drunterliegen hast, kann es dazu noch sein, dass sich WinUAE jedesmal selbst abschießt, wenn es zwischen Nativ und Graka umschaltet.

Da ich aber nicht auf mein Amiga Uhr auf dem Desktop verzichten möchte, habe ich WinUAE deswegen kaum noch an.

Doofer Grund irgendwie, aber WinUAE ist die einzige Anwendung, die das nicht gebacken bekommt ...

vlg,

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

[ - Antworten - Zitieren - Direktlink - ]

11.10.2014, 16:24 Uhr

Pfau_thomas
Posts: 71
Nutzer
Zitat:
Original von angel77:
Wenn ich dich richtig verstehe, dann vermutest du richtig.

Und wenn du einen komfortabel eingerichteten Desktop unter Win drunterliegen hast, kann es dazu noch sein, dass sich WinUAE jedesmal selbst abschießt, wenn es zwischen Nativ und Graka umschaltet.

Da ich aber nicht auf mein Amiga Uhr auf dem Desktop verzichten möchte, habe ich WinUAE deswegen kaum noch an.

Doofer Grund irgendwie, aber WinUAE ist die einzige Anwendung, die das nicht gebacken bekommt ...

vlg,

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

Bei mir stürzt WinUAE nur dann ab,wenn ich die Workench meinetwegen bei 1024*768 Punkte und 24Bit Farben wähle und dann z.B. DPaint V im Ham Modus laufen lasse .


[ - Antworten - Zitieren - Direktlink - ]

12.10.2014, 14:47 Uhr

angel77
Posts: 832
Nutzer
Genau bei so einem Wechsel zwischen PAL und RTG meine ich. Ist hier genauso. Das macht die ganze Geschichte relativ unbenutzbar, weil man für die Systemkonfiguration erstmal ständig zwischen PAL und RTG wechseln muss, beispielsweise wenn man in die Early Startup Control will / muss.

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

[ - Antworten - Zitieren - Direktlink - ]

12.10.2014, 14:59 Uhr

Pfau_thomas
Posts: 71
Nutzer
Zitat:
Original von angel77:
Genau bei so einem Wechsel zwischen PAL und RTG meine ich. Ist hier genauso. Das macht die ganze Geschichte relativ unbenutzbar, weil man für die Systemkonfiguration erstmal ständig zwischen PAL und RTG wechseln muss, beispielsweise wenn man in die Early Startup Control will / muss.

@ngel
--
http://www.privatepassion.de - @ngel's private Seite


Das kann aber der echte Amiga aber auch nicht richtig.
Ich hatte zwar zu Zeiten als ich einen Amiga4000 hatte keine Grafigkarte drinn.Aber die vom Media Verlag aus Scheidegg erzählten mir davon als die Grafigkarten Retina von Macro Sytems ,Picasso von Phase 5 im Anmarsch waren.Also wenn ich die Workbench mit 1024*768 Punkte und 24Bit Farben laufen lasse und dann Dpaint IV mit einer Pal oder Ham Auflösung startete dann schmiert der Amiga darin immer ab.

[ - Antworten - Zitieren - Direktlink - ]

12.10.2014, 18:53 Uhr

angel77
Posts: 832
Nutzer
Unsinn. Ich weiß zwar nicht wie es bei genau der Karte war, aber ich hatte zuerst ne gefixte Merlin, danach irgendwann ne BVision und dann ne Voodoo5/5000.

Diese Probleme hatte ich nie. Außerdem schmiert der WinUAE bei der Umschaltung zwischen RTG nach PAL ab und das unabhängig ob es sich um einen normalen Reset handelt oder ob ein Programm geöffnet werden soll.

Das passiert auch nicht immer, nur manchmal.

Zuerst hatte WinUAE Probleme mit einem Kalendertool, welches ähnlich wie Outlook den aktuellen Monat zeigt, wenn man mit dem Mauszeiger über der Uhr in der Taskleiste hovert. Und meine Amiga Uhr auf dem Desktop mag er auch nicht. So wie ich das kenne hat er vermutlich auch noch Probleme mit Rocket Dock.

Das hat vielleicht mit Overlay zu tun?

Ändert aber nix an der Tatsache, dass der WinUAE der einzige Emulator ist, der seine Bildschirmdarstellung nicht gebacken bekommt. Was hab ich davon, dass hinten immer mehr (wirklich tolle) Features eingebaut werden, wenn da anscheinend bei der grundsätzlichen Initialisierung was schief gelaufen ist?

Für mich fühlt sich dass nach nem Memory-Leak oder so an, dass jetzt schon seit geraumer Zeit mit rumgeschleppt wird.

Damit will ich WinUAE garnicht schlecht reden, aber ich benutze ihn hauptsächlich deswegen kaum bis garnicht mehr. Als Amiganer ist man ja Warten gewohnt ... *lach* ...

vlg,

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

[ - Antworten - Zitieren - Direktlink - ]

12.10.2014, 20:04 Uhr

thomas
Posts: 7647
Nutzer
@angel77:

Da du der einzige bist, bei dem der Fehler auftritt, wird er auch nie behoben, es sei denn, du meldest ihn mal.


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

12.10.2014, 20:34 Uhr

xXSoul-Reaver-2006Xx
Posts: 751
Nutzer
Hi

Ich lass hier über Problem das Screen Wechsel bei RTG und Pal im WinUAE, nun das gab es schon bei Original Amiga Hardware & Picasso 4 mit Picasso96 Grafiktreiber.

Viele Amiga Anwendungen&spiele hatten einen eigenen HDInstaller, das Problem war das im Grafikkarten betrieb egal welche Auflösung man eingestellt hat ein Graues Bild sah nachdem ein Anwendung oder ein Spiel gestartet wurde.

Die Lösung was „JST“ Tool, diese habe ich bei Spiel oder Anwendungen immer benutzt und unter IconX eingesetzt, war ein bisschen Arbeit. Zum Beispiel...

CD ““
C:JST DPaintIII NOCACHE



JST wurde Später durch WHDload ersetzt nur für die Spiele&Demos aber nicht für Anwendungsprogrammen wie zum Beispiel Fantavision, Deluxe Paint III, DSS 8 usw.

Mit freundlichen Grüßen

xXSoul-Reaver-2006Xx
--
Bild: http://mypsn.eu.playstation.com/psn/profile/Andromeda-Gate.png




[ Dieser Beitrag wurde von xXSoul-Reaver-2006Xx am 12.10.2014 um 22:19 Uhr geändert. ]

[ Dieser Beitrag wurde von xXSoul-Reaver-2006Xx am 12.10.2014 um 22:22 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

12.10.2014, 23:02 Uhr

angel77
Posts: 832
Nutzer
Ich weiß ja die Lösung. Ich muss mein Windows wieder aussehen lassen wie Windows. Ich arbeite aber nunmal lieber am Amiga ... ;)

Dass ich dafür auf die alte Soft verzichten muss ... nunja ...

Ich mach halt nix mehr damit. Dafür hab ich jetzt mehr Zeit für mich.

vlg,

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

[ - Antworten - Zitieren - Direktlink - ]

13.10.2014, 13:29 Uhr

Pfau_thomas
Posts: 71
Nutzer
Zitat:
Original von xXSoul-Reaver-2006Xx:
Hi

Ich lass hier über Problem das Screen Wechsel bei RTG und Pal im WinUAE, nun das gab es schon bei Original Amiga Hardware & Picasso 4 mit Picasso96 Grafiktreiber.

Viele Amiga Anwendungen&spiele hatten einen eigenen HDInstaller, das Problem war das im Grafikkarten betrieb egal welche Auflösung man eingestellt hat ein Graues Bild sah nachdem ein Anwendung oder ein Spiel gestartet wurde.

Die Lösung was „JST“ Tool, diese habe ich bei Spiel oder Anwendungen immer benutzt und unter IconX eingesetzt, war ein bisschen Arbeit. Zum Beispiel...

CD ““
C:JST DPaintIII NOCACHE



JST wurde Später durch WHDload ersetzt nur für die Spiele&Demos aber nicht für Anwendungsprogrammen wie zum Beispiel Fantavision, Deluxe Paint III, DSS 8 usw.

Mit freundlichen Grüßen

xXSoul-Reaver-2006Xx
--
Bild: http://mypsn.eu.playstation.com/psn/profile/Andromeda-Gate.png




[ Dieser Beitrag wurde von xXSoul-Reaver-2006Xx am 12.10.2014 um 22:19 Uhr geändert. ]

[ Dieser Beitrag wurde von xXSoul-Reaver-2006Xx am 12.10.2014 um 22:22 Uhr geändert. ]

Sag ich doch ,das der echte Amiga schon mit der Vermischung von RTG und Pal Auflösungen Probleme hatte. WinUAE bildet den Amiga direkt selbst mit dessen Macken nach.

[ - Antworten - Zitieren - Direktlink - ]

13.10.2014, 17:48 Uhr

angel77
Posts: 832
Nutzer
Komisch. Mein Amiga ist dabei niemals abgestürzt.

vlg,

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

[ - Antworten - Zitieren - Direktlink - ]

20.10.2014, 12:48 Uhr

Thore
Posts: 2266
Nutzer
Hab ich bei meinen auch noch nie festgestellt. Okay, ich verwende die CV64/3D, vielleicht liegts daran.

[ - Antworten - Zitieren - Direktlink - ]

20.10.2014, 13:38 Uhr

angel77
Posts: 832
Nutzer
Die beiden haben halt keine Ahnung oder lesen nicht richtig.

Was die beiden meinen ist einfach, dass der Amiga natürlich den Monitorausgang "umschaltet". Das ist kein Absturz.

vlg,

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

[ - Antworten - Zitieren - Direktlink - ]

20.10.2014, 17:00 Uhr

Thore
Posts: 2266
Nutzer
Aaaah ja klar. Das RGB Signal ist ja auch auf einem anderen Port.

RGB Port über Denise/Agnus <----- ChipRAM
VGA Port der Grafikkarte <---- VideoRAM der Grafikkarte

Weiß aber normal jeder der ne Grafikkarte im Amiga hat...

[ - Antworten - Zitieren - Direktlink - ]

20.10.2014, 19:57 Uhr

Wolfman
Posts: 3664
Nutzer
Tja, meine P IV hatte iirc einen eingebauten FliFi oder Monitorumschalter (sorry falls ich Mist schreibe, ist zu lange her :( ), da gabs sowas nicht - aber gut, da gabs mit Picasso96 keine ziehbaren Bildschirme, was ja nicht amigalike war (ich aber eigentlich nie vermisst habe) :P
--
God forgives - who forgives God ?

[ - Antworten - Zitieren - Direktlink - ]

21.10.2014, 02:55 Uhr

angel77
Posts: 832
Nutzer
Meine Merlin hat das Signal damals durchgeschliffen. Das war auch ziemlich klasse. Überhaupt war das in vielen Punkten eigentlich eine ziemlich geniale Karte. Man könnte fast sagen es war die Picasso in älter.

Mit der BVision und der Voodoo hab ich dann später allerdings natürlich noch nen Flickerfixer eingebaut gehabt und der iiyama hatte ja zwei Eingänge. Das Umschalten war aber schon relativ nervig ...

Im Gegensatz dazu verabschiedet sich einfach der komplette UAE bei der Umschaltung und produziert auch keinen Amiga-Seitigen Absturz. Es kann aber sein, dass dann beim nächsten Start eine gelbe Guru-Meldung kommt oder sogar der ganze Rechner neu gestartet werden muss, damit UAE wieder läuft. Sogar abmelden und neu anmelden ist dann zu wenig. Ein Verhalten, dass ich von anderen Programmen heutzutage eigentlich fast garnicht mehr kenne.

vlg,

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

[ - Antworten - Zitieren - Direktlink - ]

21.10.2014, 08:41 Uhr

Thore
Posts: 2266
Nutzer
Dann war das aber ein Bug im UAE :)
Ja soweit ich weiß hat die CV643D auch ein Steckerport um einen FliFi durchzuschleifen, um eine 1-Monitor-Lösung zu erhalten.

[ - Antworten - Zitieren - Direktlink - ]

21.10.2014, 08:55 Uhr

analogkid
Posts: 2383
Nutzer
Die Piccolo-Karten (also auch die SD64) hatten auch einen internen Umschalter.

[ - Antworten - Zitieren - Direktlink - ]

21.10.2014, 12:29 Uhr

angel77
Posts: 832
Nutzer
Stimmt. Gut möglich, dass ich den FliFi schon bei der Merlin im 1200er mit ZIV irgendwann hatte ... Da hatte ich aber noch den Multisync dran. Ich kann das also nicht mehr mit Bestimmtheit sagen ...

vlg,

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

[ - Antworten - Zitieren - Direktlink - ]

21.10.2014, 14:08 Uhr

Thore
Posts: 2266
Nutzer
Schade daß die Steckerleiste bei der CV64/3D ein Ausgang ist, und kein Eingang ;) Sonst hätte man die Indivision drauf adaptieren können.
Na mal schauen wie ich eine 1-Monitor-Lösung bauen kann.

[ - Antworten - Zitieren - Direktlink - ]

21.10.2014, 23:46 Uhr

angel77
Posts: 832
Nutzer
Wenn beide Signale 30khz bringen, dann ist die einfachste Lösung halt ein Monitor mit zwei Eingängen ...

Wobei ich mir garnicht sicher bin, die neuen Flachbildfernseher haben doch auch immer noch VGA/DVI/HDMI mit bei. Da müsste man doch sogar ohne FliFi beides anschließen können?

vlg,

@ngel
--
http://www.privatepassion.de - @ngel's private Seite

[ - Antworten - Zitieren - Direktlink - ]


-1- 2 [ - Beitrag schreiben - ]


amiga-news.de Forum > AROS und Amiga-Emulatoren > WinUAE 2.9.0 und PPC [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.