amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > AROS und Amiga-Emulatoren > Abeits des freudigen ereignises (64Bit JIT in WinUAE), [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

04.12.2015, 08:12 Uhr

L-ED
Posts: 391
Nutzer
Grüße in die Runde

Seit kurzem existiert auch eine 64Bit JIT Emulation (endlich, wer hatte daran noch geglaubt)! :)

In dem Zusammenhang bzw. eher eines aufgeflammten review/reloaded Projektes was bissel zeitgleich gefallen, mir eine seltsame Anomalie aufgefallen (die vermutlich schon sehr lange vorhanden?)!

Es scheint als würden beim compilieren irgend ungünstige Parameter gesetzt, die welche die mögliche Performance auf AMD FX Prozessoren erheblich drücken (vergleichsweise). Wenn an dem was dran sein könnte, wäre die nächste Frage ob da wer Draht zum Autor hätte und drauf aufmerksam machen könnte (ideal jemand mit Programmier kenntnis, wegen selber .. aka direkterer Sprache)?

Da sehr vermutlich keine Absicht dahinter sondern schlicht *Unwissen* drum, im Sinne das zum einen kaum einer mehr so extrem Projekte am schieben wo das erstens überhaupt am auffallen. Zum anderen da vermutlich selber eine andere CPU am nutzen (wahrscheinlich Intel)? ;)

Zum Verifizieren vor Ort 2x FX8 der Vishera Generation (4 und 3,2GHz) und eine Phenom 2 X6 mit 2,7GHz!

Letzterer schlägt beim Raytracing bzw. Scanline mit Cinema 4D 4.1 FP, den 3,2GHz recht deutlich und hängt auch den FX8 mit 4GHz ab! :O Und an dem Punkt Leuten bei mir die Glocken, habe zwar wenig bis im Grunde keine Ahnung vom Programmieren (auf der ebene), aber das da was quer hängen muss ist relativ offensichtlich?

Fürs Plastischere, dieses Frame brauchte:

WinUAE 3.2 64Bit (JIT)
X6 2,7 Ghz = 4:19 Min
FX8 3,2 GHz = 6:36 Min
FX8 4,0 GHz = 5:13 Min

WinUAE 3.2 64Bit (NoJIT)
X6 2,7 Ghz = 4:18 Min
FX8 3,2 GHz = 6:31 Min
FX8 4,0 GHz = 5:12 Min

Jeweils ein und die selbe Konfiguration nebst Amiga Festplatten Verzeichnis! Weitere Interessante Beobachtung, JIT OFF zu nehmen scheint offensichtlich nicht zu funktionieren (BUG)!


PS:
Es ist allgemein bekannt das die FX u.a. eine seichte FPU schwäche haben können, auch gemessen an der Ph2 Generation (speziell noch wenn man sie falsch anspricht, was ich hier vermute). Aber so unter dimensional per-formen die nun auch nicht und abseits von jetzt hier WinUAE ist das auch kaum so nachzuzeichnen. Im Regelfall braucht ein FX der Vishera Generation 200 bis max. 400MHz mehr um mit den Phenom 2 gleich auf und ab da an dann drüber zu kommen (pro Kern Leistung), so zumindest bei meinen eigenen bisherigen Beobachtungen.

Von dem her finde die Werte da oben schon ziemlich auffällig und diverse Konstellationen durchprobiert! Auch mit älteren WinUAE Versionen (allerdings nur als Quick Test).

Ok normal nicht weiter wild und erwarte auch nicht das der Autor mit Begeisterung sich da rein hängt falls es tiefer stecken sollte? Aber wenn es nur irgend ungünstig gesetzte oder vergessene Flags bei den Compiler Parameter, sollte es doch daran nicht scheitern?! :)

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > AROS und Amiga-Emulatoren > Abeits des freudigen ereignises (64Bit JIT in WinUAE), [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.