amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > PFS3 und Acard Adapter mit SSD [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

20.06.2016, 22:00 Uhr

foobargt
Posts: 137
Nutzer
Hallo,

ich bekomme die Woche einen Acard 7220U geliefert und möchte den ganz gerne an einer Blizzard 1260 50 Mhz via SCSI Kit betreiben. Daran soll eine SSD(2,5 Transcend 64 GB).

Gibt es irgendwelche Erfahrungswerte welche Einstellungen ich da in PFS3(Halt HDToolBox) am Besten eintrage? Ich würde die SSD gern in 2 Partitionen teilen.

Wie ist das eigentlich: Muss dann auch am SCSI Adapter die 1. Partition unter 2 GB sein, oder ist das dort dann anders?

Ich hatte noch nie direkt mit SCSI oder dem SCSI Kit zu tun, von daher ist das für mich alles Neuland

Was anderes: Derzeit betreibe ich PFS3 auf einer CF Disk. Ich habe diese gerade in einem WinPC unter WinUAE und wunder mich das das Kopieren der Files so extrem langsam ist. Ich habe realAmiKit drauf und das Classes-Verzeichniss ist ja elendig gross. Da sind über 8000 Files drin. Die sind alle nicht gross, aber das kopieren dauert ewig. Der Rest der Platte war eigentlich recht fix vom Backup auf der CF, nur das dauert ewig. Wieso das Verzeichniss ToolbarImages in Classes aber so extrem gross ist, erschliesst sich mir nicht so ganz und warum das so elendig langsam beim Kopieren ist....

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 14:05 Uhr

thomas
Posts: 7667
Nutzer
@foobargt:

Zitat:
Gibt es irgendwelche Erfahrungswerte welche Einstellungen ich da in PFS3(Halt HDToolBox) am Besten eintrage?

Erfahrungswerte habe ich nicht, aber in der Theorie ist ja bekannt, dass SSDs etwas anders arbeiten als Festplatten.

Das einfachste ist die Ausrichtung der Partitionen. Wenn du beim Installieren der SSD darauf achtest, dass Blocks Per Cylinder auf 2048 steht, dann werden die Partitionen automatisch an Megabyte-Grenzen ausgerichtet.

4K Blöcke kann man einstellen, bringt aber nur bei FFS etwas. Bei PFS steht in der Anleitung, dass es ohnehin immer 512-Byte-Blöcke benutzt und bei SFS steht, dass es mit anderen Blockgrößen langsamer wird.

Beim Kauf der SSD solltest du darauf achten, dass sie Wear Leveling und Garbage Collection selber macht, denn das AmigaOS unterstützt weder TRIM noch irgend was anderes SSD-spezifisches.


Zitat:
Muss dann auch am SCSI Adapter die 1. Partition unter 2 GB sein, oder ist das dort dann anders?

Erstmal sind es 4GB und es hat nichts mit SCSI oder IDE zu tun, sondern damit, was der Treiber kann oder eben nicht.

Bei SCSI bietet es sich an, PFS3DS zu benutzen. Ansonsten können soviel ich weiß alle Controller(-Treiber) von Phase5 TD64, also ist PFS3 hier auch die erste Wahl.


Zitat:
Ich habe diese gerade in einem WinPC unter WinUAE und wunder mich das das Kopieren der Files so extrem langsam ist. Ich habe realAmiKit drauf und das Classes-Verzeichniss ist ja elendig gross. Da sind über 8000 Files drin. Die sind alle nicht gross, aber das kopieren dauert ewig. Der Rest der Platte war eigentlich recht fix vom Backup auf der CF, nur das dauert ewig.

Ist mir gestern auch aufgefallen als ich das neue AISS entpackt habe. Zuerst ging es rasend schnell aber auf einmal gab es einen Ruck und es kamen nur noch 2 oder 3 Dateien pro Sekunde. Scheint ein Problem von PFS3 mir riesigen Verzeichnissen zu sein.


Zitat:
Wieso das Verzeichniss ToolbarImages in Classes aber so extrem gross ist, erschliesst sich mir nicht so ganz

http://www.amiga-news.de/de/news/AN-2016-06-00037-DE.html


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 15:00 Uhr

foobargt
Posts: 137
Nutzer
@thomas:
So viel Auswahl gibts bei IDE SSDF ja nicht. Vielmehr als Transcend hatte ich nicht gefunden.

Interessant das mir die HDToolbox dort zwar was um die 60 GB Fassungsvermögen anzeigt, aber ich tatsächlich nur 30 Partitionieren kann. Ich habe dann die ersten 3,8 GB als AmiKit Laufwerk gemacht. und die anderen 26 GB als Work...

Mask und MaxTransfer habe ich als Standard belassen. Blockgrösse wie in der Anleitung auf 512 gesetzt.

Ich habe den PFS3-aio im L: drin.. Das sollte ja dafür da sein. Oder muss ich das originale PFS3ds nehmen?

Starten tut das Ganze auch. Nur die 2. Partition ist immer NDOS. Wenn ich diese formatiere, dann ist das nach dem reboot auch wieder weg und wieder NDOS. An der Max-Partition sollte das ja nichjt liegen. Soweit ich weis ist das Maximum als Partition irgendwas bei 100 GB oder so

Ich habe die aber erstmal nur am internen IDE Adapter getestet, da der ACARD noch nicht da ist....



Wegen dem Datentransfer: Das Backup in WinUAE hab ich über Umwege nun gemacht. Erstmal alles rein kopieren, bis auf Classes und dann Classes in die Ram-Disk und von dort aus dann auf die Karte/SSD drauf. Geht um Welten schneller als direkt... Komisch, is aber irgendwie so...

[ Dieser Beitrag wurde von foobargt am 21.06.2016 um 15:02 Uhr geändert. ]



NACHTRAG: Hab das was du sagtest noch mal geprüft. Hatte deine Angabe mit Blockgrösse Dateisystem verwechselt. Ich habe jetzt 2048 angegeben und jetzt lassen sich auch die 60 GB partitionieren. Das was in der Anleitung steht sind ja die im Dateisystem. Die lasse ich mal auf 512. Ich werde also nochmal alles kopieren und dann weiter sehen :)

[ Dieser Beitrag wurde von foobargt am 21.06.2016 um 15:44 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 15:51 Uhr

Goja
Posts: 278
Nutzer
Zitat:
Original von thomas:
Wenn du beim Installieren der SSD darauf achtest, dass Blocks Per Cylinder auf 2048 steht, dann werden die Partitionen automatisch an Megabyte-Grenzen ausgerichtet.

Ach und was ist mit dem Startblock / Erster Sektor? Wenn der mitten in einem "echten" Block liegt ist das wohl nicht optimal (zumindest bei normalen Festplatten).

Bezüglich der Partition, die sich nach dem reboot nicht anmeldet: Ist das Dateisystem dafür auch im RDB?
--
http://www.baud.de Amiga A4000T MC68060RC50 PPC604E@233Mhz 274Mb OS3.9 & OS4.0

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 15:55 Uhr

foobargt
Posts: 137
Nutzer
@Goja:

Beide Partitionen nehmen das identische Filessystem. Also PFS3-aio

Mir ist aber vorhin nochwas aufgefallen. AmiKit hat wohl beim Update mir das SCSI-Device runter gesetzt. Ich habe laut HDToolBox die Version 40 irgendwas, vorher war das noch v ersion 43 irgendwas. Wenn ich das grad richtig gegoogelt habe, dürfte das auf jeden Fall auch ein Grund für den Fehler sein


NACHTRAG: Habs gefunden. AmiKit 8.6 hat mir in die startup-sequence "SetPatch SKIROMUPDATE "scsi.device" QUIET reingehauen. Hab die Mitte jetzt gelöscht und das durch "SetPatch QUIET" ersetzt....
Muss noch die SSD auf WinUAE fertig machen. Mal sehen ob es dann besser funzt

Nachtrag 2: Im netz finde ich unterschiedlichste Angaben zum Buffer. Viele haben den auf 80, einige auf 30 runter geregelt und einige haben die Empfehlung gegeben den auf 300 zu setzen. Welche Auswirkungen hat das denn genau?

[ Dieser Beitrag wurde von foobargt am 21.06.2016 um 16:05 Uhr geändert. ]

[ Dieser Beitrag wurde von foobargt am 21.06.2016 um 16:14 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 16:16 Uhr

thomas
Posts: 7667
Nutzer
Zitat:
Ach und was ist mit dem Startblock / Erster Sektor? Wenn der mitten in einem "echten" Block liegt ist das wohl nicht optimal (zumindest bei normalen Festplatten).

Es gibt keine Startblöcke, nur Startzylinder. Deshalb ist es ja so geschickt, ein Megabyte als Zylindergröße zu benutzen, weil dann automatisch alle Partitionen auf Megabytegrenzen liegen.

Bei normalen Festplatten kann man nicht mitten in einem echten Block liegen, weil ein echter Block (512 Bytes) die kleinste adressierbare Einheit ist.

Das geht nur bei Advanced Format (4K-Blöcke), wenn kleinere Blöcke emuliert werden. Und das gilt natürlich genauso für SSDs, auch da werden 4K-Blöcke benutzt.

Bei SSDs kommt noch erschwerend hinzu, dass sie nur 128K oder 256K Blöcke auf einmal schreiben können. Deshalb müssen bei SSDs die Partitionen nicht nur auf 4K sondern auf 128K bzw. 256K ausgerichtet sein.

Mit MB-Grenzen ist man in jedem Fall auf der sicheren Seite.


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 16:19 Uhr

thomas
Posts: 7667
Nutzer
@foobargt:
Zitat:
AmiKit hat wohl beim Update mir das SCSI-Device runter gesetzt.


Wenn du AmiKit benutzen möchtest, solltest du wissen was du tust. Denn die Designer von AmiKit wissen definitiv nicht was sie tun.

AmiKit ist hübsch anzusehen, zum Arbeiten aber nicht zu gebrauchen.


Zitat:
Nachtrag 2: Im netz finde ich unterschiedlichste Angaben zum Buffer. Viele haben den auf 80, einige auf 30 runter geregelt und einige haben die Empfehlung gegeben den auf 300 zu setzen. Welche Auswirkungen hat das denn genau?

Lies einfach die Anleitung von PFS3.


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 16:44 Uhr

foobargt
Posts: 137
Nutzer
@thomas:

"Wenn du AmiKit benutzen möchtest, solltest du wissen was du tust. Denn die Designer von AmiKit wissen definitiv nicht was sie tun.

AmiKit ist hübsch anzusehen, zum Arbeiten aber nicht zu gebrauchen."

Das Gefühl bekomme ich langsam auch. Beim letzten Update hat mir das so viele Einstellungen geschossen. Die Oberfläche sieht echt genial aus, aber so langsam werde ich mich davon wohl doch verabschieden. Hab keine Lust bei jedem Update alles neu zu machen :(
Ich selber hatte seit ettlichen Jahren nix mehr mit Amiga zu tun. Hatte dann aber vor paar Wochen die Wahl entweder alles zu verticken, was ich nich wollte, oder mal damit los zu legen. Hab mich dann fürs 2. entschieden. Dummerweise ist recht viel, recht neu für mich....


"Lies einfach die Anleitung von PFS3."

Hab ich, werde nur aus einigem nicht ganz schlau :P

Nachtrag: Die Platte läuft jetzt :) Danke für deinen Tip :) Das mit dem Buffer muss ich da dennoch erstmal raus suchen.....

[ Dieser Beitrag wurde von foobargt am 21.06.2016 um 16:57 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 17:29 Uhr

thomas
Posts: 7667
Nutzer
@foobargt:

Puffer:

30 ist der Default von HDToolbox OS 3.1.
80 ist der Default von HDToolbox OS 3.9.
PFS3 braucht min. 150 und max. 600.

Mit 300 bist du gut bedient.


--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 17:40 Uhr

foobargt
Posts: 137
Nutzer
@thomas:

Vielen Dank. hab die Seite im Guide auch gefunden. Hatte ich wohl übersehen...
Wenn ich das richtig lese, dann dürfte das auch das andere Problem sein, was ich beim Dateitransfer aus dem riesigen Classes Ordner hatte. Ich werde das mal hochsetzen. Sollte ich sogar stressfrei 400 oder 450 nehmen können.

So ganz schnalle ich das mit der Maske und dem MaxTransfer nicht. Also die Anleitung mit MaxTransfer kapiere ich schlicht und ergreifend nicht wirklich.... Genauso das mit der Mask

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 20:16 Uhr

thomas
Posts: 7667
Nutzer
@foobargt:

Über Mask und MaxTransfer kann man dem Dateisystem Einschränkungen des Controllers mitteilen. Dementsprechend kann man die richtigen Werte hierfür auch nicht in der Anleitung des Dateisystems finden, sondern sie müssen in der des Controllers stehen.

Über die Maske kann das Dateisystem prüfen, ob der übergebene Puffer für DMA geeignet ist. Dafür wird das Bitmuster der Maske mit dem der Pufferadresse verglichen.

Soviel zur Theorie. Praktisch kann man die Maske aus zwei Teilen zusammensetzen:

linker Teil:

ffff.... keine Einschränkung
7fff.... nur die ersten 2GB (bei AmigaOS das gleiche wie keine Einschränkung)
00ff.... nur im 24bit-Speicher (Zorro2)
007F.... nur in den ersten 8 MB (Chip-RAM)

rechter Teil:

....ffff keine Ausrichtung notwendig
....fffe nur auf geraden Adressen
....fffc nur auf Adressen, die durch 4 teilbar sind

Das SCSI-Kit macht DMA glaube ich nur in seinen eigenen Speicher, der im oberen Bereich des Adressraums liegt. Da sollte die Standardmaske von 7ffffffe funktionieren.


MaxTransfer bestimmt den größten Block, der mit einem Befehl über den SCSI-Bus übertragen werden kann. Das ist ähnlich wie die MTU im Netzwerkbereich.

Ein korrekt programmierter Treiber sollte hier keine Einschränkungen haben, sondern die Aufteilung automatisch vornehmen. D.h. man kann hier problemlos ffffff oder mehr reinschreiben.

Da am Ende ein IDE-Gerät steckt und der IDE-Befehlssatz ohnehin nur 128k auf einmal übertragen kann, kann der MaxTransfer-Wert 1fe00 aber auch nicht schaden. Insbesondere wenn du die SSD mal an den internen IDE anschließen möchtest, der Treiber hat da nämlich so seine Probleme mit neueren Laufwerken.




--
Email: thomas-rapp@web.de
Home: thomas-rapp.homepage.t-online.de/

[ - Antworten - Zitieren - Direktlink - ]

21.06.2016, 20:24 Uhr

foobargt
Posts: 137
Nutzer
Vielen Dank. Hätten se das mal in die Anleitung geschriebemn. Das versteht man wenigstens nach dem 3. Lesen :D

Dann sollte ich dort die Standardwerte drin lassen können. Am internen IDE funktioniert das jetzt auch. Ich habe nur den Puffer hochgesetzt, was ja glücklicherweise den Daten drauf nicht schadet.

Aber trotzdem nochmal Danke. Im Netz findet man leider immer nur "Trag mal das ein" oder "versuch das mal". Aber was das dann auch heisst und die Konsequenz, die sieht man leider nicht wirklich. Aber gerade bei einem Dateisystem sollte das schon ein wenig hinterfragt werden, sonst kann man sich den Spass auch schenken.

Im Übrigen: Spätestens nach deiner Aussage werde ich mich von AmiKit verabschieden und das alles nochmal selber drauf pappen. Etwas schade, da ein Autoupdater schon sehr praktisch ist und man viel Zeugs auf einmal drauf hat. Auf der anderen Seite halb so wild, hab hier nämlich noch eine alte Opus Magellan 2 Lizenz rum fliegen. Damit kann man sich es auch nett einrichten :D

[ - Antworten - Zitieren - Direktlink - ]

28.06.2016, 20:18 Uhr

foobargt
Posts: 137
Nutzer
Also mit PFS3 kriege ich irgendwie nicht hin.... Ich habe jetzt schon mehrere Sachen probiert, aber irgendwie habe ich dann immer komische Fehler.

Installiert ist AmiKit.
Ich habe in L: jetzt PFS3, PFS3ds und PFS3aio
Das ganze mit der SSD am SCSI-Kit der Blizzard 1260 66.
Mit Mediator und Radeon 9200. Dazu RapidRoad USB.
Am internen IDE ist eine CF Card und als Slave ein CDRom angeklemmt

Wenn ich starte, dann bekomme ich gleich zu beginn eine Virus Warnung von wegen "Happy Christmas" Virus und das irgendein Safe-File ne andere Grösse hätte.
Ist dann DOpus gestartet auf der Radeon, dann habe ich komische Grafikfehler.
Ich habe auch den 50iger Quarz wieder in die Blizzard zum Testen gemacht und kann ausschliessen das dort der Takt dazwischen funkt.
Ich habe auch mehrere Masken ausprobiert da waren bei 0x7FFFFFFE, 0x7FFFFFFFC, dann das ganze noch ohne die 7 und ein F mehr. Ist immer das gleiche. Ich hatte als Filessystem die PPFS3ds genommen. Sollte ja eigentlich richtig sein.

Ich habe jetzt mal die Platte mit FFS formatiert um auszuschliessen das was mit dem System nicht passt. Mit FFS läuft alles einwandfrei(Daten sind aus dem gleichen Backup, also identisch)

Ich habe also keine Ahnung wo ich ansetzen könnte zur Fehlerbehebung, damit PFS3 läuft. Ich würde ja schon gern da das Maximum raus holen, was mit FFS jetzt nicht unbedingt der Fall ist


Nachtrag: Das ich alle drei Dateien von PFS3 drin hab in L(also PFS3, PFS3ds und PFS3aio), dürfte ja nix machen. Oder? Weil in der Toolbox haben ja alle drei die gleiche ID.

NACHTRAG 2: Jetzt gehts. Habe diesmal PFS3 und nicht PFS3ds genommen. Habe die anderen auch aus L gelöscht. Und plötzlich ist das Problem weg. Frage mich wieso. Gerade am SCSIKit dachte ich müsste ich PFS3ds nehmen.... Verstehe ich nicht. Ausserdem wundert mich etwas der Speed. Sysinfo sagt mit auf DH0(die ersten 3,8 GB) 6,5 MB/s Speed und auf DH1(Die restlichen 60 GB) nur 3,8 MB Speed... komisch

[ Dieser Beitrag wurde von foobargt am 29.06.2016 um 10:13 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > PFS3 und Acard Adapter mit SSD [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.