amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Amiga, AmigaOS 4 > Blizzard PPC im Amiga 1200? [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 -2- [ - Beitrag schreiben - ]

04.10.2016, 13:21 Uhr

foobargt
Posts: 137
Nutzer
@dandy:


Nette IDee. Auf die bin ich auch nicht gekommen. Da ich jetzt alles via ACard am SCSI klemmen hab, könnte ich das Ding auch abschalten. Ich habe gerade mal fix gegoogelt und ich finde da nix für den A1200.
Ist natürlich auch die Frage ob das beim A1200 nötig ist, wenn da nix dran klemmt....
--
Amiga 1200, Blizzard 1260/66 SCSI Kit, 256 MB RAM, RapidRoad USB, 2xACARD 7220U 64 GB SSD+DVD ROM, Mediator 1200TX, Radeon 9200/128, 100 MBit LAN PCI, CF Card Reader, AmigaOS 3.9+AfAOS+DOpus 5

MacMini G4, 1,5 Ghz, 128 GB SSD, Morphos 3.9

[ - Antworten - Zitieren - Direktlink - ]

04.10.2016, 14:33 Uhr

dandy
Posts: 2552
Nutzer
Zitat:
Original von foobargt:
@dandy:

Nette IDee. ... Ich habe gerade mal fix gegoogelt und ich finde da nix für den A1200.


BlizKick-Module: Disables IDE-interface (Software - ReadMe)

Disable IDE interface on OS3.x and A4000 (Software - ReadMe)

Zitat:
Original von foobargt:

Ist natürlich auch die Frage ob das beim A1200 nötig ist, wenn da nix dran klemmt.
...


Wenn ich mich recht entsinne, dann sucht der Amiga erst mal am internen IDE Port nach Geräten.

Festplatten brauchen unterschiedlich lange, bis sie sich selbst initialisiert haben und vom Bus aus ansprechbar sind. Daher hat das SCSI.device, welches auch den IDE Bus steuert, ein Timeout.

Wenn gar kein Gerät am IDE hängt, dann wartet AmigaOS bis das Timeout-Signal kommt und sucht erst dann an evtl. vorhandenen SCSI Host Adaptern weiter.

Von daher könnte auch im 1200er das Abschalten des internen IDE Kontrollers schon Sinn machen...
--
Ciao,

Dandy

Wenn es jemandem Spaß macht, zu Marschmusik in Reih` und Glied zu marschieren, so verachte ich ihn schon.
Er hat sein Großhirn nur aus Versehen bekommen - bei ihm hätte auch schon das Rückenmark gereicht!
(Albert Einstein)

[ - Antworten - Zitieren - Direktlink - ]

04.10.2016, 15:28 Uhr

foobargt
Posts: 137
Nutzer
@dandy:

Danke. Werde ich mir mal ansehen.

Wird wohl doch mal Zeit mich in Blizkick rein zu frickeln. Hab mich da bissl rum gedrückt bisher :P

NACHTRAG: Da fällt mir wieder ein warum ich mich um Blizkick gedrückt hab. Meine Fresse ist das kompliziert :P
--
Amiga 1200, Blizzard 1260/66 SCSI Kit, 256 MB RAM, RapidRoad USB, 2xACARD 7220U 64 GB SSD+DVD ROM, Mediator 1200TX, Radeon 9200/128, 100 MBit LAN PCI, CF Card Reader, AmigaOS 3.9+AfAOS+DOpus 5

MacMini G4, 1,5 Ghz, 128 GB SSD, Morphos 3.9

[ Dieser Beitrag wurde von foobargt am 04.10.2016 um 15:48 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

05.10.2016, 14:55 Uhr

Holger
Posts: 8082
Nutzer
Zitat:
Original von dandy:
Wenn ich mich recht entsinne, dann sucht der Amiga erst mal am internen IDE Port nach Geräten.



Wenn gar kein Gerät am IDE hängt, dann wartet AmigaOS bis das Timeout-Signal kommt und sucht erst dann an evtl. vorhandenen SCSI Host Adaptern weiter.


Es ist nicht wichtig, in welcher Reihenfolge der Amiga die Adapter abklappert, das kann sogar theoretisch parallel erfolgen. Dan entscheidende ist, dass er in jedem Fall auf den IDE Bus wartet, vollkommen unabhängig davon, ob an anderen Kontrollern etwas gefunden wurde.

Die Logik ist

1. Alle Geräte finden
2. Nach Bootpriorität sortieren (falls nicht im Bootmenü explizit ausgewählt)
3. Vom Gerät mit höchster Priorität und eingelegtem Medium booten

Also, ja, das Abschalten/Überspringen des IDE-Scans bringt in jedem Fall etwas.

Ich denke, der für den A4000 gedachte Hardware-Hack sollte auch funktionieren, wenn man die Logik vom 3,5" Konnektor auf den 2,5" Konnektor übersetzt. Die zusätzlichen Pins kommen ans Ende, d.h. wenn man bei Pin 1 zu zählen beginnt, ändert sich nichts.

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

05.10.2016, 21:01 Uhr

foobargt
Posts: 137
Nutzer
Ich habe das auch mit dem Hack jetzt geregelt bekommen.
Also mit Blizkick komme ich nicht klar.... Ist mir zu kompliziert....
--
Amiga 1200, Blizzard 1260/66 SCSI Kit, 256 MB RAM, RapidRoad USB, 2xACARD 7220U 64 GB SSD+DVD ROM, Mediator 1200TX, Radeon 9200/128, 100 MBit LAN PCI, CF Card Reader, AmigaOS 3.9+AfAOS+DOpus 5

MacMini G4, 1,5 Ghz, 128 GB SSD, Morphos 3.9

[ - Antworten - Zitieren - Direktlink - ]

06.10.2016, 15:08 Uhr

Rotzloeffel
Posts: 219
Nutzer
[quote]
Original von foobargt:
Zitat:
Was meinst du mit richtig einstellen? kannst du mir da ein paar Tips geben? Drauf habe ich das ja schon plus BPPCfix und PPLibemu...

Wegen Warp3D: Ich habe zwar noch eine Voodoo5 hier, die ich eigentlich auch gern verbaut hätte, aber dummerweise hat die nur einen VGA Anschluss, was mein TV aber nicht hat.


da fängt es schon mal an:-) den BPPCfix brauchst du mit der aktuellen Version von WarpOS nicht mehr, das kannst du dort einstellen....

Hier ist die Bibel: http://www.a1k.org/forum/showthread.php?t=27585

bis auf die Einstellungen für den Terminator kannst du alles so übernehmen.... dort muss Terminator2 und earlyTerm angewählt werden, das ersetzt den BPPCfix.....

Die Videoadresse liefert dir pciinfo

Kauf dir nen Monitor für die Voodoo..... is besser so....:)

[ Dieser Beitrag wurde von Rotzloeffel am 06.10.2016 um 15:09 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

06.10.2016, 16:21 Uhr

foobargt
Posts: 137
Nutzer
@Rotzloeffel:


Vielen Dank für den Link. :)


Naja, ich lass die Voodoo erstmal im Schrank. Wenn ich jetzt noch nen extra Monitor kaufe, dann tritt mich meine Frau in die Eier. Also bleibts beim TV :P
--
Amiga 1200, Blizzard 1260/66 SCSI Kit, 256 MB RAM, RapidRoad USB, 2xACARD 7220U 64 GB SSD+DVD ROM, Mediator 1200TX, Radeon 9200/128, 100 MBit LAN PCI, CF Card Reader, AmigaOS 3.9+AfAOS+DOpus 5

MacMini G4, 1,5 Ghz, 128 GB SSD, Morphos 3.9

[ - Antworten - Zitieren - Direktlink - ]

07.10.2016, 10:25 Uhr

dandy
Posts: 2552
Nutzer
Zitat:
Original von foobargt:

Ich habe das auch mit dem Hack jetzt geregelt bekommen.
...


Prima!
Welchen "Hack" meinst Du? Den Hardware-Hack oder den (nicht-Blitzkick-)Software-Hack?
Und - um wieviel ist der Bootvorgang bei Deinem 1200er jetzt dadurch schneller geworden?
--
Ciao,

Dandy

Wenn es jemandem Spaß macht, zu Marschmusik in Reih` und Glied zu marschieren, so verachte ich ihn schon.
Er hat sein Großhirn nur aus Versehen bekommen - bei ihm hätte auch schon das Rückenmark gereicht!
(Albert Einstein)

[ - Antworten - Zitieren - Direktlink - ]

07.10.2016, 12:25 Uhr

foobargt
Posts: 137
Nutzer
@dandy:


Den hier: http://de4.aminet.net/disk/misc/NoIDE13.readme

Also mir wird jetzt kein SCSI Device mehr angezeigt...

Wie viel schneller das geworden ist, das kann ich so nicht genau sagen. Hab ich nicht nachgemessen. Ich hatte auf jedenfall schon das Gefühl das der Start ohne Hack und mit Abklemmen des letzten Gerätes vom IDE schneller wurde. Ich denke aber schon das es was gebracht hat.
Also für diesen völlig überzüchteten Amiga ist die Startzeit so eigentlich völlig OK. Mit OS3.9 only würde das wohl nochmal gut schneller gehen, aber AfaOS und Dopus5 sind halt nunmal echt gute Sachen auf die ich wegen bissl Bootzeit echt nicht verzichten möchte :)
Aber sollte ich am WE mal Langeweile haben(unwahrscheinlich :D ) teste ich mal die Bootzeiten exakt :D
--
Amiga 1200, Blizzard 1260/66 SCSI Kit, 256 MB RAM, RapidRoad USB, 2xACARD 7220U 64 GB SSD+DVD ROM, Mediator 1200TX, Radeon 9200/128, 100 MBit LAN PCI, CF Card Reader, AmigaOS 3.9+AfAOS+DOpus 5

MacMini G4, 1,5 Ghz, 128 GB SSD, Morphos 3.9

[ - Antworten - Zitieren - Direktlink - ]

07.10.2016, 13:29 Uhr

dandy
Posts: 2552
Nutzer
Zitat:
Original von foobargt:
@dandy:

Den hier: http://de4.aminet.net/disk/misc/NoIDE13.readme


Achso.

Zitat:
Original von foobargt:

...
Also für diesen völlig überzüchteten Amiga ist die Startzeit so eigentlich völlig OK.


Das mag durchaus sein.

Zitat:
Original von foobargt:

...
Mit OS3.9 only würde das wohl nochmal gut schneller gehen, aber AfaOS und Dopus5 sind halt nunmal echt gute Sachen auf die ich wegen bissl Bootzeit echt nicht verzichten möchte :)


Hmmm - AfaOS.
Wie ist das so?

Ich bin vorsichtig geworden mit 3rd Party OS-Komponenten.

Hatte vor einiger Zeit mal so einen "Updater" (Grunch) installiert, der mir die "neuesten Versionen" von allen möglichen Libraries, DosDrivern, DataTypes, (Mui-)Classes usw. heruntergeladen und installiert hat.

Erstmal habe ich nichts Negatives bemerkt.

Das kam dann, als ich unlängst "Netsurf für OS3" antesten wollte und mein Miggy plötzlich aus unerklärlichen Gründen abstürzte.

Ich habe dann mit Chris (Young) in seinem Netsurf-Thread auf Amiga.org herausgearbeitet, dass da irgendwelche "neuesten Library Versionen", die mir "Grunch" installiert hatte, von irgendwelchen Drittanbietern stammten und nicht mehr zu den originalen Versionen kompatibel waren.

Habe dann OS3.9/WarpOS mit den beiden originalen BoingBags neu installiert.

Komme jetzt beim Start von NetSurf etwas weiter und kann den Splash-Screen sehen, bevor der Rechner sich aufhängt. Muss also noch mehr Dinge wieder in den "Originalzustand" zurückversetzen, die ich aber erst mal alle herausfinden muss. Eine ziemlich zeitaufwändige Angelegenheit. So was wie "Grunz" tue ich mir garantiert kein zweites Mal an...

Ich brauche NetSurf zwingend, um einen "modernen Browser" zu haben, mit dem ich mir dann den DropBox-Zugangscode herunterladen kann, um meinen Amiga DropBox-Handler endlich ans Laufen zu bekommen.

Könnte mir vorstellen, das der Einsatz von Workbench-Alternativen wie AfaOS da auch unverhofft Probleme mit neuer Software machen könnten.
--
Ciao,

Dandy

Wenn es jemandem Spaß macht, zu Marschmusik in Reih` und Glied zu marschieren, so verachte ich ihn schon.
Er hat sein Großhirn nur aus Versehen bekommen - bei ihm hätte auch schon das Rückenmark gereicht!
(Albert Einstein)


[ Dieser Beitrag wurde von dandy am 09.10.2016 um 14:45 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

07.10.2016, 16:05 Uhr

foobargt
Posts: 137
Nutzer
Zitat:
"Hmmm - AfaOS.
Wie ist das so?"


Naja, es sorgt auf ner 1280x720iger Workbench dafür das das nicht total grütze aussieht :D
Also gerade die Schriftarten sind mir wichtig und auch das man die besseren Icons hat. Dadurch kann man mit der Workbench auch in der hohen Auflösung leben. Das sieht dann sogar recht modern aus. Ich persönlich kann es empfehlen. Wirklich grosse inkompatibilitäten habe ich bisher nicht gefunden. Ausser Quake von ClickBoom, das läuft nicht mit. Aber da gibts ja andere Ports aus dem Aminet :P

Zitat:
"Hatte vor einiger Zeit mal so einen "Updater" (Grunch) installiert, der mir die "neuesten Versionen" von allen möglichen Libraries, DosDrivern, DataTypes, (Mui-)Classes usw. heruntergeladen und installiert hat."


Hatte ich auch mal probiert. Ist definitiv nix für mich unter OS3... Ausserdem hat das auch zu wenig Software drin gehabt für OS3. Bei MorphOS ist das eher schon was :)

Zitat:
"Ich brauche NetSurf zwingend, um einen "modernen Browser" zu haben, mit dem ich mir dann den DropBox-Zugangscode herunterladen kann, um meinen Amiga DropBox-Handler endlich ans Laufen zu bekommen.
"



NetSurf würde mich auch interessieren. Wie läuft das Ding denn? Hatte bisher nur gelesen das es noch argh Buggy sein soll?
Ich finde ja iBrowse echt nett, blöde nur das da so viel nicht funktioniert. Gut, bei OWB unter Morphos geht zur Zeit auch viel nicht, aber schon bissl mehr als mit iBrowse..
Gibts von NetSurf auch ne Warp Version?
--
Amiga 1200, Blizzard 1260/66 SCSI Kit, 256 MB RAM, RapidRoad USB, 2xACARD 7220U 64 GB SSD+DVD ROM, Mediator 1200TX, Radeon 9200/128, 100 MBit LAN PCI, CF Card Reader, AmigaOS 3.9+AfAOS+DOpus 5

MacMini G4, 1,5 Ghz, 128 GB SSD, Morphos 3.9

[ Dieser Beitrag wurde von foobargt am 07.10.2016 um 16:06 Uhr geändert. ]

[ Dieser Beitrag wurde von foobargt am 07.10.2016 um 16:06 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

09.10.2016, 14:50 Uhr

dandy
Posts: 2552
Nutzer
Zitat:
Original von foobargt:

...
NetSurf würde mich auch interessieren. Wie läuft das Ding denn?
...


Wie ich schon schrieb, kann ich es noch nicht starten. Mein Rechner friert immer ein, wenn der Splashscreen kommt...
Muss noch herausfinden, warum das System während des Netsurf Starts abkackt...
Habe aber im Moment wenig Zeit...
--
Ciao,

Dandy

Wenn es jemandem Spaß macht, zu Marschmusik in Reih` und Glied zu marschieren, so verachte ich ihn schon.
Er hat sein Großhirn nur aus Versehen bekommen - bei ihm hätte auch schon das Rückenmark gereicht!
(Albert Einstein)

[ - Antworten - Zitieren - Direktlink - ]


1 -2- [ - Beitrag schreiben - ]


amiga-news.de Forum > Amiga, AmigaOS 4 > Blizzard PPC im Amiga 1200? [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.