amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Programmierung > XorRectRegion erzeugt falsche RegionStruct [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

26.01.2018, 23:41 Uhr

Reth
Posts: 1753
Nutzer
Hallo zusammen,

hab mir ziemlich verschachtelte Klassen usw. in C++ gebastelt, um einige AOS-API-Funktionen zu kapseln und ne Art "Grafikengine" zu bauen.

Im wesentlichen soll bei einem Spielfeld ein Clipbereich bestimmt werden, der alle umgebenden Rechtecke enthält von den darzustellenden Objekten, die geändert dargestellt werden wollen.
Bei animierten/sich bewegenden Objekten wird dabei der alte Bereich und der neue Bereich dazu genommen.

Um die festen Statusbereiche zu schützen, füge ich die Rechtecke derselben mit OrRectRegion hinzu und nehme sie mit XorRectRegion wieder weg. Das sollte eigentlich dafür sorgen, dass diese Bereiche nicht Teil der zu ändernden Fläche sind.

Das Ganze funktioniert laut LogAusgaben und dem was ich sehe auch, aber wenn ich mir die Ausgaben genau anschaue, läuft das Bilden der Region bei den zu schützenden Statusbereichen an einer Stelle immer aus dem Ruder. Hier mal ein Log-Auszug - es erfolgt ein XorRectRegion-Aufruf, mit einer RectangleStruct und der bestehenden Region:
C++ code:
xorNewRectangle mit rectangleStruct top: 15 left: 808 right: 1023 bottom: 230 gerufen
XorRectRegion region vorher mit top: 15 left: 808 right: 1023 bottom: 651
XorRectRegion region nachher mit top: 605 left: 855 right: 1070 bottom: 1241


Ich habe eine feste Auflösung von 1024x768. Wie geht denn sowas? Ein paar Aufrufe später gehen die Koordinaten dann sogar über 15000!!!

Keine Ahnung, wie das sein kann! Denke nicht, dass hier ein Fehler im API ist (arbeite unter AOS4.1 FE), sondern dass ich noch irgendwo was falsch mache/verstehe!

Was könnte das sein?

Abgesehen vom komplexen Clipping, wäre hier ein Ansatz mit Layern oder so besser, um die geschützten Bereich zu implementieren?

Dank euch schon mal!

Ciao

[ Dieser Beitrag wurde von Reth am 28.01.2018 um 17:36 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

29.01.2018, 22:36 Uhr

Reth
Posts: 1753
Nutzer
Das Seltsame ist auch, dass diese Code-Stelle mehrfach durchlaufen wird und "nur" beim 2. Durchlauf kommen diese irrsinnigen Koordinaten zustande - bei allen anderen Durchläufen davor und danach sind alle Werte korrekt!

Die Adressen der verwendeten Objekte und Strukturen bleiben dieselben, ebenso die verwendeten Werte für die Rechtecke!

[ - Antworten - Zitieren - Direktlink - ]

29.01.2018, 23:53 Uhr

Reth
Posts: 1753
Nutzer
Ok, konnte meine Vermutung bestätigen: Ich hatte beim Re-Installieren der alten Region den dabei zurück gegebenen Wert eben dieser alten Region zugewiesen im Dickicht meiner Methoden.
Das erklärt das seltsame Auftreten beim 2. Mal, weil ab dann die Region immer dieselbe ist (soweit meine Erklärung dafür).

Ein Problem weniger!

[ - Antworten - Zitieren - Direktlink - ]

31.01.2018, 18:57 Uhr

Holger
Posts: 8038
Nutzer
Ja, aber warum nicht einfach ClearRectRegion statt OrRectRegion gefolgt von XorRectRegion benutzen?

--
Good coders do not comment. What was hard to write should be hard to read too.

[ - Antworten - Zitieren - Direktlink - ]

31.01.2018, 20:09 Uhr

Reth
Posts: 1753
Nutzer
@Holger:

Joaaa ... guter Punkt ... :D

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > Programmierung > XorRectRegion erzeugt falsche RegionStruct [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.