amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > Forum und Interna > Eingeloggt bleiben [ - Suche - Neue Beiträge - Registrieren - Login - ]

1 -2- [ - Beitrag schreiben - ]

16.06.2020, 11:41 Uhr

DaxB
Posts: 1411
Nutzer
Zitat:
Original von cgutjahr:Derzeit solltest du sechs tage lang angemeldet bleiben.
Hmm... hier ist LOGIN_ID (immer noch) 14 Tage gültig. Ich muss mich aber nicht neu anmelden nach der Zeit, bzw. es findet wohl ein Autologin statt.

[ - Antworten - Zitieren - Direktlink - ]

17.06.2020, 09:02 Uhr

Reth
Posts: 1812
Nutzer
@cgutjahr:
Ich denke, dass immer noch ein Problem vorliegt, da ich wie gesagt abgemeldet bin, auch wenn ich die Links aus den Mails nehme, die mir Amiga-News schickt und ich davor noch angemeldet war.

Auch wenn ich z.B. amiga-news via Google suche und ich dann übers Portal dahin navivigiere bin ich nicht mehr angemeldet, auch wenn ich ne Weile (oder einen Tag) davor noch angemeldet war.

[ - Antworten - Zitieren - Direktlink - ]

17.06.2020, 16:39 Uhr

DaFreak
Posts: 251
Nutzer
@cgutjahr:
Ich teste das mal aus. Habe mich gestern wieder neu einloggen müssen und mal schauen, wie lange es hält. Wenn ich mich also erst nächste Woche melde, dann passt das mit den 6 Tagen. :)
Wäre aber trotzdem etwas sehr kurz für eine News&Forumseite, findest du nicht?
--
Sam440ep + AmigaOS4.1 im Morex 3677 Gehäuse

[ - Antworten - Zitieren - Direktlink - ]

17.06.2020, 22:32 Uhr

Reth
Posts: 1812
Nutzer
Also bei mir ist es sogar so, dass ich auf einer Seite, bei der ich eingeloggt war (sieht man ja an der Farbkennung) wieder ausgeloggt werde, wenn ich einfach nen Reload mache!

Der Computer war zwischenzeitlich 1h bis 2h im Ruhezustand, die Seite aber offen im Browser!

Der ursprüngliche Link auf die Seite (bin mal alles zurück gegangen) kam aus ner E-Mail von Amiga-News, mit Info, dass auf meinen Beitrag geantwortet wurde (nutze GMX online im Browser).

[ - Antworten - Zitieren - Direktlink - ]

17.06.2020, 23:04 Uhr

cgutjahr
Posts: 2712
[Administrator]
Zitat:
Original von Reth:
Also bei mir ist es sogar so, dass ich auf einer Seite, bei der ich eingeloggt war (sieht man ja an der Farbkennung) wieder ausgeloggt werde, wenn ich einfach nen Reload mache!

Der Computer war zwischenzeitlich 1h bis 2h im Ruhezustand, die Seite aber offen im Browser!

Okay, das ist wirklich merkwürdig. Du hast zwischenzeitlich keinen anderen Browser/Smartphone benutzt, um auf die Seite zuzugreifen?

Bei "eingeloggt bleiben" unterhalb des Anmeldeformulars hast du einen Haken gesetzt?

Die Firefox-Cookie-Settings sind auch okay - also nicht etwa Domain-spezifisch oder Allgemein irgendetwas konfiguriert, was dir da in die Quere kommen könnte?

[ - Antworten - Zitieren - Direktlink - ]

16.07.2020, 12:43 Uhr

DaFreak
Posts: 251
Nutzer
Zitat:
Ich teste das mal aus. Habe mich gestern wieder neu einloggen müssen und mal schauen, wie lange es hält.

Kurzer Zwischenstand: Heute ist fast ein Monat vorbei und ich bin immernoch angemeldet. D.h. die Probleme müssen bei mir mit verschiedenen Endgeräten zu tun haben, da ich sonst zusätzlich auf Tablet & Smartphone das Login nutzte.

[ Dieser Beitrag wurde von DaFreak am 16.07.2020 um 12:44 Uhr geändert. ]

[ - Antworten - Zitieren - Direktlink - ]

19.07.2021, 11:57 Uhr

Mikkel
Posts: 2
Nutzer
Ich buddel dieses alte Thema mal wieder aus, weil mich das Problem ärgert seit ich mir einen Account zugelegt habe (lange Zeit habe ich nur als Gast geschrieben)

Ich habe mir das mal genauer angeschaut. Euer Server setzt vier Cookies: "PHPSESSID" unbefristet, "cookie_post" 4 Wochen befristet, "LOGIN_ID" 2 Wochen befristet, "cookie_comThr" 2 Wochen befristet. Keines davon setzt die Cross Origin Policy, sodass es überhaupt keine Rolle spielen sollte ob http oder https.

Das tägliche Erleben deckt sich aber nicht mit den genannten Fristen. Ein Login hält bei mir zwischen wenigen Minuten und 3 Tagen, aber nie länger.

Ich habe jetzt mal darauf geachtet und nachgeschaut, bevor ich auf eure Seite gehe, ob die Cookies noch vorhanden und gültig sind. Das ist der Fall. Darum kann ich mit relativ hoher Wahrscheinlichkeit sagen, dass das Problem serverseitig ist.

Da das Cookie "PHPSESSID" gesetzt ist vermute ich einfach mal, es handelt sich um einen klassischen Shared-Webspace auf einem LAMP-Server? Möglicherweise pfuscht da irgendetwas in den Session-Cache des Servers? phpinfo() gibt da evtl. Auskunft.

Werden die Session-Caches verschiedener Scripte evtl. sogar an verschiedenen Orten gespeichert? PHP nutzt standardmäßig das Dateisystem, manche Webhoster biegen das aber auch in eine Datenbank um. Dito für Scripte, in denen ein Cookie "zu Fuß" erzeugt wird.

Ich würde empfehlen, serverseitig das ganze Cookie-Handling zu überarbeiten, nur noch ein einziges zu benutzen (PHPSESSID reicht!) und die Laufzeit auf unbegrenzt/undefiniert zu setzen, wenn man beim Login die Checkbox ankreuzt. Dann nehmen die meisten Browser 365 Tage an.

[ - Antworten - Zitieren - Direktlink - ]

19.07.2021, 15:02 Uhr

DaxB
Posts: 1411
Nutzer
@Mikkel:
"PHPSESSID" ist hier gültig bis zum Ende der Sitzung.
"cookie_post" habe ich hier nicht.

Ansonsten funktioniert es hier, dass ich angemeldet bleibe.

[ - Antworten - Zitieren - Direktlink - ]

20.07.2021, 13:39 Uhr

Mikkel
Posts: 2
Nutzer
Ich empfehle mal das hier durchzulesen. Das bestätigt a) meine Vermutung, dass hier 1&1 im Session-Cache herum pfuschen könnte und b) welche Möglichkeiten der Abhilfe es gibt.

[ - Antworten - Zitieren - Direktlink - ]


1 -2- [ - Beitrag schreiben - ]


amiga-news.de Forum > Forum und Interna > Eingeloggt bleiben [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.