amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > AROS und Amiga-Emulatoren > WinUAE V 0.8.22 Konfig [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

11.09.2002, 13:42 Uhr

ArminHuebner
Posts: 1349
Nutzer
Betrifft WinUAE V 0.8.22: Hat jemand einen Link, der Hilfe für die Konfiguration anbietet?

Ansonsten hätte ich hier einige Fragen:

Habe 256 MB DDR Ram auf dem Mainboard und 64 MB DDR Ram auf der Grafikkarte.

Welche Ram-Einstellungen sind in diesem Fall die Besten in WinUAE?

Was bedeutet die Option Idle CPU?

Gruß, Armin.

[ - Antworten - Zitieren - Direktlink - ]

11.09.2002, 14:13 Uhr

dandy
Posts: 2552
Nutzer
Zitat:
Original von ArminHuebner:
Betrifft WinUAE V 0.8.22: Hat jemand einen Link, der Hilfe für die Konfiguration anbietet?

Ansonsten hätte ich hier einige Fragen:

Habe 256 MB DDR Ram auf dem Mainboard und 64 MB DDR Ram auf der Grafikkarte.

Welche Ram-Einstellungen sind in diesem Fall die Besten in WinUAE?

Was bedeutet die Option Idle CPU?

Gruß, Armin.

Wenn Du weißt, ob die von Dir genannte UAE-Version in AmigaForever 5.0 verwendet wird, kann ich Dir vielleicht helfen, indem ich Dir meine Einstellungen dort "abfotografiere" und Dir die screenshots maile.



[ - Antworten - Zitieren - Direktlink - ]

11.09.2002, 14:19 Uhr

dandy
Posts: 2552
Nutzer
Zitat:
Original von ArminHuebner:
Betrifft WinUAE V 0.8.22: Hat jemand einen Link, der Hilfe für die Konfiguration anbietet?

Ansonsten hätte ich hier einige Fragen:

Habe 256 MB DDR Ram auf dem Mainboard und 64 MB DDR Ram auf der Grafikkarte.

Welche Ram-Einstellungen sind in diesem Fall die Besten in WinUAE?

Was bedeutet die Option Idle CPU?

Gruß, Armin.

Wenn Du weißt, ob die von Dir genannte UAE-Version in AmigaForever 5.0 verwendet wird, kann ich Dir vielleicht helfen, indem ich Dir meine Einstellungen dort "abfotografiere" und Dir die screenshots maile.
Was die Option "idle CPU" genau macht, weiß ich auch nicht - habe sie noch nie benutzt.
Aber "idle" heißt "Leerlauf"...
Übrigens solltest Du Dir ein Bookmark auf den folgenden Link setzen, wenn Du mal öfter eine Vokabel nicht weißt:
http://dict.leo.org/

Ist echt gut - kennt auch viele umgangssprachliche und Fachaudrücke.


[ - Antworten - Zitieren - Direktlink - ]

11.09.2002, 17:20 Uhr

thomas
Posts: 7668
Nutzer

Auf http://www.back2roots.org gibt es für jedes bekannte Spiel eine Beispielkonfiguration.

Allgemein kann man sagen:

für einen A500 (zum Spielen):

Chipset = OCS
512KB chip
512KB slow
alles andere auf "none"
ROM = Version 1.3 oder 1.2
CPU = 68000, "match A500 speed"
kein uaescsi.device
keine bsdsocket.library
keine Festplatte
höchstens 2 Floppy-Laufwerke
floppy speed = 100%

für einen A1200 (zum Spielen von "AGA" Spielen):

Chipset = AGA
2MB Chip
alles andere auf "none"
ROM = Version 3.1
CPU = 68020
Jit Cache je nachdem, ob es Probleme gibt auf 4MB oder 0.
kein uaescsi.device
keine bsdsocket.library
keine Festplatte

für die Workbench:

2MB chip
64MB zorro
4MB RTG
ROM = Version 3.1
CPU = 68040
"Fastest possible"
Cache size = 4MB
uaescsi.device = an
bsdsocket.library = an
möglichst viele Festplatten :-)
Floppy speed = turbo

Alles andere solltest du auf der Voreinstellung lassen, wenn du nicht weißt, was es bewirkt.

"CPU idle detection" bewirkt, daß bestimmte Maschinensprache-Instruktionen, die den 680x0 schlafen legen (z.B. STOP) abgefangen werden und auch die Emulation schlafengelegt wird. Das bewirkt, daß der PC-Prozessor nicht ständig zu 100% ausgelastet ist, sondern wenn das Amiga Multitasking nichts tut auch die Emulation nichts tut. Für Spiele sollte man das tunlichst ausschalten.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

11.09.2002, 18:49 Uhr

ArminHuebner
Posts: 1349
Nutzer
Hallo, Thomas.

Also, spielen tue ich nicht.

Bei V0.8.22 erscheint ein recoverable Alert, sobald die S-S aufgerufen wird.
Bei meiner durch Amiga Forever installierten vorherigen V 0.8.17 ist das
Problem nicht aufgetreten.

Ich habe bisher noch nicht herausfinden können, ob die Sache durch andere
Einstellungen in der WinUAE-Konfiguration behoben werden kann.

Kann man Fast Ram eigentlich ohne Kompatibilitätsprobleme auf Null setzen?
Zur Zeit habe ich 8 MB eingegeben.

Meine Wb-Auflösung ist 1024x768 und funktioniert ab 4 MB RTG-Ram.
Habe ich einen Vorteil, wenn ich dort mehr RAM spendiere?

Hier ist die Sytem-Auswertung:

Evaluating system...
Central Processing Unit: MC68040 557.9 MHz
Floating Point Unit: 68040fpu
Memory Management Unit: 68040mmu not active
Custom graphics chip: AGA Lisa 4203 (rev 0)
Custom animation chip: AGA PAL Alice 8374, rev 3-4
Other custom chip(s): Paula 8364 (rev 0), Gary (rev 0)
Graphics system: Picasso96
Hardware Clock: clock found
Max. Chipmem available: 2048 K
Max. Fastmem available: 73728 K
ROM chip version: 40.68 (Kickstart 3.1)
Workbench version: 45.3 (Workbench )
SetPatch version: 44.38
Expansion board(s):
2011/1: Reserved UAE - RAM Expansion (@$00200000 8M)
2011/3: Reserved UAE - RAM Expansion (@$10000000 64M)
2011/96: Reserved UAE - Graphics Expansion (@$14000000 16M)
2011/2: Reserved Resource Management - QuickNet 2000 (@$00E90000 64k)

Your computer is some Amiga or compatible, run by UAE Amiga Emulator.

Gruß, Armin.





[ - Antworten - Zitieren - Direktlink - ]

11.09.2002, 22:39 Uhr

thomas
Posts: 7668
Nutzer
Zitat:
Bei V0.8.22 erscheint ein recoverable Alert, sobald die S-S aufgerufen wird.

Welche Fehlernummer ? Von welchem Programm ?

Zitat:
Kann man Fast Ram eigentlich ohne Kompatibilitätsprobleme auf Null setzen?

Hat ein A1000 Fast-RAM ? Nein. Hat ein A500 Fast-RAM ? Nein. Hat ein A600 Fast-RAM ? Nein. Hat ein A1200 Fast-RAM ? Nein. Frag lieber, ob man ohne Kompatibilitätsprobleme überhaupt Fast-RAM einstellen kann. Außerdem ist alles, was nicht Chip-RAM ist Fast-RAM. Der Zorro-Einsteller hat den Vorteil, daß man bis 512MB einstellen kann.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

12.09.2002, 03:49 Uhr

M0rpheus
Posts: 1041
Nutzer
Erstell mal eine neue Konfiguration für 0.8.22, OHNE die alte zu benutzen denn einige features gegenüber 0.8.17 vertragen sich nicht wirklich mit 0.8.22 ;) Hat bei mir den Rec.Alert behoben !
--
M0rpheus / Amiga Projekt Zone
http://apz.8m.com/index.html

[ Dieser Beitrag wurde von M0rpheus am 12.09.2002 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

12.09.2002, 04:33 Uhr

Michael_Mann
Posts: 1012
Nutzer
Hi,

an den Einstellungen sollte man eigentlich nur im Bereich der emulierten CPU und des/r RAM-Größen großartig herumspielen. Alles andere nur sehr behutsam und am Besten unter Notierung der Grundeinstellungen, es gibt leider keine UNDO-Funktion.
Aufpassen muß man halt auch bei der Druckereinstellung. Hier gilt erst die Einstellungen abspeichern, den Requester ganz verlassen (ohne UAE-Start) und dann durch Doppel-Klick auf die entsprechende Konfig-Datei UAE starten.
Bei den weiteren Treibern darauf achten das auch die tatsächlich installierten Treiber angezeigt werden. WIN bietet zugerne auch sog. primäre Sound/Gfx-Treiber an.
Ich denke das es nicht verkehrt ist die Option "MMU" aktiviert zu lassen. Hat man versehentlich mal ein Proggi/Lib mit MMU-Unterstützung installiert kann das ansonsten durchaus einen Guru hervorrufen.
Sound am besten auf emuliert aber nicht aktiviert einstellen (wenn keine Soundausgabe gewünscht ist). Es könnte sein das ansonsten das eine oder andere Programm recht giftig reagiert.
Auch dran denken möglichst nur Hardfiles einzusetzen, FAT32 und FFs beißen sich gelegentlich gar heftigst und kann ebenfalls einen GURU bzw. einen UAE-Absturz auslösen.

Letztendlich auch nicht ganz vergessen das UAE leider nur so gut sein kann wie das Host-System ist... 8)

Bernd, der 2te, hat in seinen HowTos eine Formel angegeben wie man den Speicherverbrauch von UAE berechnet. Allgemein sollten bereits 8 MByte für den Gfx-Speicher und 16 MByte FASTRam ausreichend sein (alles andere am besten auf Null). Amiga-Proggis brauchen halt mal nur unverschämt wenig Speicher. :D


Michael


[ Dieser Beitrag wurde von Michael_Mann am 12.09.2002 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

12.09.2002, 07:30 Uhr

ArminHuebner
Posts: 1349
Nutzer
Michael_Mann:

> Ich denke das es nicht verkehrt ist die Option "MMU" aktiviert zu lassen.

Wo denn?

> Allgemein sollten bereits 8 MByte für den Gfx-Speicher und 16 MByte FASTRam ausreichend sein...
> Amiga-Proggis brauchen halt mal nur unverschämt wenig Speicher. :D

Unter 64 MB Fast Ram sollte man m.E. nicht gehen, denn das würde auf jeden Fall Probleme mit Ibrowse geben...

Armin.

[ - Antworten - Zitieren - Direktlink - ]

12.09.2002, 08:10 Uhr

ArminHuebner
Posts: 1349
Nutzer
thomas:

> Welche Fehlernummer ? Von welchem Programm ?

Der Guru ist nicht mehr reproduzierbar.
Ich glaube, es lag an verkehrten Sound-Einstellungen.

Armin


[ - Antworten - Zitieren - Direktlink - ]

12.09.2002, 14:09 Uhr

Michael_Mann
Posts: 1012
Nutzer
Zitat:
> Ich denke das es nicht verkehrt ist die Option "MMU" aktiviert zu lassen.

Wo denn?

> Allgemein sollten bereits 8 MByte für den Gfx-Speicher und 16 MByte FASTRam ausreichend sein...
> Amiga-Proggis brauchen halt mal nur unverschämt wenig Speicher. :D

Unter 64 MB Fast Ram sollte man m.E. nicht gehen, denn das würde auf jeden Fall Probleme mit Ibrowse geben...

Armin.



Hi,

MMU -> in dem man den entsprechenden Prozessor aktiviert (68020 oder 68040). Wegen der Abwärtskompatibilität der Motorolas kann mann es ruhig mit dem 68040er versuchen, sollte da keine Probleme geben. Willst Du UAE ganz ausreizen dann installiere noch make060 (Aminet). Das Tool sorgt dafür das dann auch reine 060-Programme lauffähig sind.

Und das mit dem IBrowse - ich verwende hier AWeb (OpenSource) in der 060er Version. Der scheint nicht so speicherhungrig wie der IBrowse zu sein.


Michael


[ - Antworten - Zitieren - Direktlink - ]

13.09.2002, 09:00 Uhr

thomas
Posts: 7668
Nutzer

Erzähl doch nicht so einen Quatsch. UAE emuliert keine MMU und ein emulierter 68060 ist keinen deut schneller oder besser als ein emulierter 68020. Der Emulator emuliert den Befehlssatz, die Geschwindigkeit des richtigen Prozessors begründet sich aber in der Architektur (Cache, Recheneinheiten etc). Deshalb gilt bei der Emulation: um so einfacher der Befehlssatz um so schneller die Emulation. Im Prinzip müßte der 68020 unter UAE der schnellste Prozessor sein.

Beim 68060 kommt noch hinzu, daß ihm einige Instruktionen des 68040 fehlen, sodaß diese vom AmigaOS nachgebildet werden müssen. Das kostet Rechenzeit, ist also langsamer als ein 68040.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

13.09.2002, 09:30 Uhr

hjoerg
Posts: 3810
Nutzer
Hi Thomas,

meine Version (auch die von Armin) emuliert gar kein 060, maximal 040.

@ArminHübner

Wenn ich das richtig lese hast Du den AGA-Modus eingestellt.
Erstens brauchst Du den nicht für die WB und zweitens steht dort auch etwas von 'very bugy'. Ergo ausschalten und ESC aktivieren.

@all
Bei mir funzt eigentlich alles wunderbar, bin echt überascht !
Ich kann auch an den Einstellungen viel ausprobieren.

Ich habe mal alle meine Programme getestet und versucht diese 'zum Absturz' zu bringen, ist mir nicht gelungen !!!

Sogar Quake 040 funzt mit 20fps in 800x600 !

Auch der oft bemängelte Sound funzt eigentlich sehr gut, vorallem die AHI-emu mit 16bit 44khz Stereo++ läuft locker mit.

Auch die CD-Nutzung ist einfach, nur anklicken und schon hatte ich das OS3.5 von der CD aus installiert.

Der Datenaustausch AMIGA-PC ist ja lustig, da kann man einfach von beiden Seiten aus alles machen !
:itchy:

Aber auch mal ne' Frage :Kann ich eigentlich auch eine AMIGA-FP am IDE_BUS anschliessen und nutzen ?
(Option: Alle PC-Laufwerke beim Start mounten)

Jupp ich würde gerne noch ein paar Erfahrungen mit Nutzern der Version .22R1 austauschen ! Gibt's auch irgendwo ein deutsches Forum ? Oder schon ein aktuelleres HELP-File ?
--
CU by
---AMIGA-DREAM 2002---
---with XXL :lach:
hjörg :dance2:



[ Dieser Beitrag wurde von hjoerg am 13.09.2002 editiert. ]

[ Dieser Beitrag wurde von hjoerg am 13.09.2002 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

13.09.2002, 13:46 Uhr

Thorty
Posts:
[Ex-Mitglied]
Klappt die CD-Rom Unterstützung bei der neuen WinUAE-Version
denn nun?

[ - Ändern - Antworten - Zitieren - Direktlink - ]

13.09.2002, 14:49 Uhr

hjoerg
Posts: 3810
Nutzer
Zitat:
Original von Thorty:
Klappt die CD-Rom Unterstützung bei der neuen WinUAE-Version
denn nun?



Hi Thorty,

die CD-ROM - Unterstützung 'klappt' perfekt bei mir.

1.Möglichkeit: Bei #Harddisk# einfach den Laufwerksbuchstaben angeben

oder

2. Die Einstellung #Add PC Drives at startup# anklicken und schon hast Du alle PC-Laufwerke auf dem AMIGA(schreiben,lesen,formatieren,Win löschen usw.)


--
CU by
---AMIGA-DREAM 2002---
---with XXL :lach:
hjörg :dance2:


[ - Antworten - Zitieren - Direktlink - ]

15.09.2002, 14:14 Uhr

Stefan1200
Posts: 1056
Nutzer
Zitat:
Original von hjoerg:
Zitat:
Original von Thorty:
Klappt die CD-Rom Unterstützung bei der neuen WinUAE-Version
denn nun?



Hi Thorty,

die CD-ROM - Unterstützung 'klappt' perfekt bei mir.

1.Möglichkeit: Bei #Harddisk# einfach den Laufwerksbuchstaben angeben

oder

2. Die Einstellung #Add PC Drives at startup# anklicken und schon hast Du alle PC-Laufwerke auf dem AMIGA(schreiben,lesen,formatieren,Win löschen usw.)


--
CU by
---AMIGA-DREAM 2002---
---with XXL :lach:
hjörg :dance2:



ähhh...das sind ja die schlechtesten Möglichkeiten um das CD-Rom zu mounten. Geht auf die Misc Seite von WinUAE und aktiviert das uaescsi.device. Nun nimmt Ihr CacheCDFS oder ähnliches CDFS, und installiert es (das CD-Rom Auswahl Tool hilft euch, entweder uaescsi.device Unit 0 oder 1, je nach PC Konfig). Dann werden auch alle CDs gelesen, die ein echter Amiga lesen kann, völlig unabhängig von Windows. Aber Achtung, bei Problemen den MaxTransfer Wert von der CD-Rom Mount Datei auf Amiga seite runter setzen. Einfach den Wert von SFS/PFS für alte SCSI Controler nehmen. Der geht 1a!
--
MfG Stefan1200

Chat im #AmigaFun -> irc.phat-net.de

Wichtig: Rechtschreibfehler entstehen nur durch die elektronische Übertragung und sind daher vom Autor nicht gewollt. :) )

[ - Antworten - Zitieren - Direktlink - ]

15.09.2002, 18:15 Uhr

hjoerg
Posts: 3810
Nutzer
Zitat:
Original von Stefan1200:
ähhh...



Aha ,das wusste ich noch nicht !
Ich werde es mal probieren, um zu sehen was da besser ist.


--
CU by
---AMIGA-DREAM 2002---
---with XXL :lach:
hjörg :dance2:


[ - Antworten - Zitieren - Direktlink - ]

15.09.2002, 19:35 Uhr

hjoerg
Posts: 3810
Nutzer
Nochmal an thomas + Stefan1200:

Ist dann auch das Mounten meiner FP(Amithlon) möglich ?

THX
--
CU by
---AMIGA-DREAM 2002---
---with XXL :lach:
hjörg :dance2:


[ - Antworten - Zitieren - Direktlink - ]

18.09.2002, 17:44 Uhr

M0rpheus
Posts: 1041
Nutzer
Im Moment ist es (noch) nicht möglich, Amiga HD's mit WinUAE zu mounten, du könntest höchtens eine Image Datei davon erstellen und als HDF einbinden :)

Aber Geduld, Toni arbeitet schon daran 8)
--
M0rpheus / Amiga Projekt Zone
http://apz.8m.com/index.html

[ - Antworten - Zitieren - Direktlink - ]

18.09.2002, 18:32 Uhr

hjoerg
Posts: 3810
Nutzer
@M0rpheus

THX !
--
CU by
---AMIGA-DREAM 2002---
---with XXL :lach:
hjörg :dance2:


[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > AROS und Amiga-Emulatoren > WinUAE V 0.8.22 Konfig [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.