amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > AROS und Amiga-Emulatoren > openpci_8139.device [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

10.02.2003, 20:53 Uhr

Jens_B
Posts: 6
Nutzer
wer hat denn das openpci_8139.device unter Amithlon zu einer Verbindung gebracht? Habe es mit MIAMI und Genesis probiert, nix.
Das Info-Tool zeigt mit die Netzwerkkarte aber an. Was kann ich tun?

[ - Antworten - Zitieren - Direktlink - ]

11.02.2003, 00:11 Uhr

Aachthor
Posts: 123
Nutzer
Das gleiche Problem habe ich mit einer G-REX. Ich frage mich ob das
Device unter der Prometheus funktioniert...
--
Amiga-only since 1989 :boing:

[ - Antworten - Zitieren - Direktlink - ]

11.02.2003, 19:51 Uhr

thomas
Posts: 7680
Nutzer

Also bei mir hat's gerade direkt beim ersten Versuch geklappt. Hab bei Miami einfach das powerne2k.device durch openpci_8139.device ersetzt und bin wieder online gegangen. Klappt. Der Router blinkt jetzt mit der grünen statt der orangenen LED (grün = 100MBit, orange = 10MBit).

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

13.02.2003, 12:48 Uhr

kadi
Posts: 1503
Nutzer
Bei mir gehts auch, ich hab in Miami noch auf "sanaII Parameters/Query device" geklickt.

Sie läuft - allerdings nicht mit den 100Mbit typischen raten. Aber schneller als meine alte 10MBit-Karte ist sie alle male.

[ - Antworten - Zitieren - Direktlink - ]

13.02.2003, 15:36 Uhr

thomas
Posts: 7680
Nutzer
Zitat:
Original von kadi:
Bei mir gehts auch, ich hab in Miami noch auf "sanaII Parameters/Query device" geklickt.

Sie läuft - allerdings nicht mit den 100Mbit typischen raten. Aber schneller als meine alte 10MBit-Karte ist sie alle male.




Hast du die Anleitung gelesen ? Du mußt in der Config-Datei die Geschwindigkeit wählen. Default ist 10MBit Halfduplex.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

14.02.2003, 01:21 Uhr

kadi
Posts: 1503
Nutzer
> Hast du die Anleitung gelesen ? Du mußt in der Config-Datei die
> Geschwindigkeit wählen. Default ist 10MBit Halfduplex.

Ja, hab ich. Ich hab mit half und full Duplex probiert, das machte aber keinen Unterschied.

Das die Karte wirklich im 100MBit Modus läuft erkenne ich auch an den LEDs meines Switches.

Ich habe mit SAMBA getestet. Unter QNX auf einem P200MMX läuft SAMBA und auf Amigaseite verwende ich nur smbfs oder SMB-handler (nur Client, den rest von SAMBA benutze ich nicht).

Upload vom Amiga zum PC geht so mit 550KB/s und download fom PC zum Amiga mit 1600KB/s.

Für 100MBit Karten ist das viel zu langsam. Aber schneller als 10MBit ist es schon.


[ - Antworten - Zitieren - Direktlink - ]

14.02.2003, 11:58 Uhr

_PAB_
Posts: 3016
Nutzer
Kann man das device nicht unter Genesis verwenden !?
(Wäre echt blöd - da ja jeder, der OS 3.9 hat auch Genesis hat - und ich bin Genesis-Fan...)

[ - Antworten - Zitieren - Direktlink - ]

14.02.2003, 14:59 Uhr

thomas
Posts: 7680
Nutzer

Natürlich kann man es mit Genesis nutzen. Das ist ein standard Sana2-Device, das kann man mit jedem TCP/IP-Stack nutzen.

Natürlich kannst du mit Genesis nicht direkt ein DSL-Modem ansteuern, weil Genesis nicht mehrere Interfaces unterstützt und es keinen PPPoE-Treiber für Genesis gibt.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

14.02.2003, 17:56 Uhr

checker
Posts: 640
Nutzer
hmm also in meiner grex will das nicht so richtig

die karte wird erkannnt auch in miami dx ist die karte da nur kann ich den rechner nicht anpingen und kann auch nicht online gehen =(

hat jemand einen tip ??

[ - Antworten - Zitieren - Direktlink - ]

16.02.2003, 11:57 Uhr

_PAB_
Posts: 3016
Nutzer
@thomas:
so selbstverständlich ist das nicht, da Sana-2 und DMA nicht gerade leicht zu programmieren sind und es schon viel Troulbe damit gab.
Daher würde es mich schon interessieren, ob es jemand mit Genesis und dem GRex4000D versucht hat - und ob es lief.

[ - Antworten - Zitieren - Direktlink - ]

06.02.2007, 22:08 Uhr

nujack
Posts: 245
Nutzer
Hallo,

wollte heute mal das openpci_8139.device mit meinem Mediator und Genesis ausprobieren. Irgenwie bekomme ich es aber nicht hin. Wenn ich das Device in den Genesis-Prefs als SANA2-Device konfiguriere und als Konfigurationsdatei die openpci_8139_0.config in ENV:OpenPCI mitgebe wird der Inhalt der ENV-Datei immer wie folgt überschrieben:

cd no
mppcomp no
vjcomp no
bsdcomp no
deflatecomp no
eof yes

In Genesis erscheint zudem folgende Fehlermeldung:

[err ]: iface_config: SIOCAIFADDR: Object exists
[crit ]: Kann Interface OpenPCI nicht konfigurieren.


PCIINFO gibt folgende Details preis:

Pci Device 5:
VendorID: $10ec
VendorName: Realtek Semiconductor
DeviceID: $8139
DeviceName: RT8139A/B/C Fast Ethernet Adapter
ClassCode: $20000
RevisionID: $10
InterruptPin: 4
SubsystemVendorID: $10ec
SubsystemID: $8139
IOSpace0: $40c06800 - $40c068ff
MemSpace1: $50002000 - $500020ff
RomSpace: $50010000 - $5001ffff

Inhalt der ENV-Datei, vor Betätigen des Online-Buttons:

0

; 0=Speed Auto Negociation
; 1=10Mb Half-Duplex
; 2=10Mb Full-Duplex
; 3=100Mb Half-Duplex
; 4=100Mb Full-Duplex


Was ich nicht verstehe, warum wird die ENV-Datei nach Betätigen des Online-Buttons mit diesen Daten überschrieben? Nutzt jemand dieses Device unter Genesis/Mediator und kann mir da weiterhelfen? Was mache ich falsch? Bin für jeden Tipp dankbar.

Gruß

nujack

[ - Antworten - Zitieren - Direktlink - ]

09.02.2007, 16:24 Uhr

Der_Wanderer
Posts: 1229
Nutzer
@JensB

Die Treiber aus dem Contrib Pack 3 funktionieren tadellos und sind für viele Ethernet Karten verfügbar, ich denke 8129 ist auch dabei.

Ich kann damit sowohl mit Miami und Genesis online gehen, wobei es mit Miami einfacher war, aber das liegt nicht am Treiber.

Im Gegensatz zu den Soundkartentreibern integrieren sie sich reibungslos in des System. Ich hatte nie Probleme mit dem Multitasking, wenn ich z.B. parallel mp3s gehört habe beim Surfen etc.

--
Thilo Köhler, Author von:
HD-Rec, Samplemanager, ArTKanoid, Monkeyscript, Toadies, AsteroidsTR, TuiTED, PosTED, TKPlayer, TKUnpacker
Homepage: http://www.hd-rec.de


[ - Antworten - Zitieren - Direktlink - ]

10.02.2007, 10:38 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
Original von Aachthor:
Ich frage mich ob das Device unter der Prometheus funktioniert...


Tut es, allerdings nur mit der neuen Prometheus-Firmware (und bevor Fragen aufkommen: das Upgrade kommt, wir arbeiten allerdings noch an einigen Goodies :-)

Mit der alten Firmware läuft es einige Zeit lang, wird aber früher oder später Fehler liefern oder den Rechner abschmieren lassen.

Michael

[ - Antworten - Zitieren - Direktlink - ]

10.02.2007, 10:59 Uhr

nujack
Posts: 245
Nutzer
@mboehmer: Und was ist mit dem MediatorBoard? Funktioniert das Device auch mit dem Mediator? Wenn ja - wie?

Gruß

nujack

[ - Antworten - Zitieren - Direktlink - ]

10.02.2007, 11:33 Uhr

mboehmer
Posts: 350
Nutzer
Zitat:
@mboehmer: Und was ist mit dem MediatorBoard? Funktioniert das Device auch mit dem Mediator? Wenn ja - wie?

Keine Ahnung. Frag am besten bei den Elbox-Leuten nach, die freuen sich sicher über Fragen zu OpenPCI :-)

Fragen zu Mediator kann und werde ich nicht beantworten - ich kenne mich ja nach offizieller Aussage besagter Firma nicht mit PCI aus... abgesehen davon, ich habe nur einen alten Mediator in einem meiner Test-Tower, der nicht mehr auf dem aktuellen Stand der Dinge ist. Und meine Motivation, darauf OpenPCI zu testen, ist eher gering.

Michael

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > AROS und Amiga-Emulatoren > openpci_8139.device [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.