amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > MorphOS > Probleme mit Poverconverter [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

13.05.2003, 11:41 Uhr

Twister
Posts: 46
Nutzer
Hi Leute,

ich versuche häufig AVI's ins MPG umzuwandeln.
Allerdings muß ich immer feststellen, das die Farben nicht immer
stimmen. Also ich meine damit, wenn ich dann das umgewandelte File
anschaue, habe ich so eine Art Schmierfilm drauf, als wenn etwas auf
dem Film herumschwimmen würde. Und dann bei der nächsten Scene ist es
wieder weg und baut sich neu auf. Es ist wirklich schlecht zu
erklären, man sollte es am besten mal sehen.
Wenn jemand weiß, was ich meine, könnte mir da einer mal helfen. Ich
komme nicht weiter.

Gruß

Twister



[ - Antworten - Zitieren - Direktlink - ]

13.05.2003, 13:49 Uhr

Frostwork
Posts: 75
Nutzer
Hallo, Twister!
Vielleicht keine direkte Hilfe, aber zumindest schonmal ne Antwort ;)
Meine MOS-version von ffmpeg funzt nicht mit dem PowerKonverter.
Stattdessen verwende ich die PPC-Version...
Wenn Du über die GUI automatisch wandeln lässt, sollte er eigentlich
die Bildqualität vom Original behalten, oder?
Viel Glück!

Ciao
Frostwork

[ - Antworten - Zitieren - Direktlink - ]

13.05.2003, 16:34 Uhr

Twister
Posts: 46
Nutzer
Jo, ich habe das eben ma getestet. Jetzt habe ich das Prob mit der
verfärbung nicht mehr, allerdings sieht es jetzt sehr pixelig aus.
Viele kleine Quadrate muß ich leider feststellen. Dazu muß ich sagen,
daß ich bei beiden Versuchen immer die Größe beibehalten habe und
möchte es ja auch lediglich in ein MPG umwandeln, ohne die Größe zu
verändern. Die Bildqualität ist dennoch bei beiden nicht so toll.

Gibt es denn nichts, was ich da noch tun könnte ?!?

Gruß

Twister

[ - Antworten - Zitieren - Direktlink - ]

13.05.2003, 17:46 Uhr

pagasos-sigi
Posts:
[Ex-Mitglied]
Twister:
Wie groß ist der "Quantiserscale" bei deinem Video?
Du mußt wissen, wenn der Quantiserscale oder einfach q-Wert zu hoch
ist, dann wird die Qualität immer schlecher.Stelle mal einfach im
Powerkonverter auf der Seite "Video" die Videobitrate auf "VBR1", oder
"VBR2". Damit gibst du ffmpeg zu verstehen, das du eine konstante
Bildqualität von 1 oder 2 haben willst. Der Nachteil ist aber, das die
Videobitrate stark schwankt.

[ - Ändern - Antworten - Zitieren - Direktlink - ]

14.05.2003, 16:08 Uhr

Twister
Posts: 46
Nutzer
Also ich hab jetzt mal alles mögliche getestet und bin zu keinem
geeignetem ergebnis gekommen. Entweder ist es zu pixelig oder ich habe
einen Schmierfilm drauf. Ist schon irgendwie eigenartig. Ich habe es
mit VBR1, VBR2 und VBR3 getestet ohne das Format zu ändern. Und wenn
ich ffmpeg automatisch konvertieren lasse wird es mehr als nur
unansehnlich. Man müßte mal ein Video nehmen, was nicht zu groß ist
und bei dem die Daten austauschen kann, um gemeinsam verschiedene
Tests durchzuführen. Oder es liegt am ffmpeg selbst. Ich weiß mir
jedenfalls nicht mehr zu helfen.

Hat vielleicht noch jemand eine andere Idee ?

Ach ja nochwas. Gibt es eigentlich auch ein txt-File für die
GOP-Size-Einstellung ? Ich habe ja schon gesucht, aber nix gefunden.
Ich bin der Meinung, wenn ich die auf 1 setzen könnte, wäer das
Problem gelöst, denn ich habe damit mal ein wenig herumexperimentiert,
nur niedriger als 100 komme ich nicht.


Gruß Twister



[ Dieser Beitrag wurde von Twister am 14.05.2003 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

15.05.2003, 17:00 Uhr

pagasos-sigi
Posts:
[Ex-Mitglied]
Twister:

Wenn du den GOP-Size ganz runter drehst (z.B.1), dann besteht das MPEG
Movie nur noch aus Vollbildern (I-Frames). Dabei erhöht sich die
Größe des Files auf das Vielfache. Abgesehen davon ist es nicht Sinn
der Sache, da MPEG's ja komprimiert sein sollen, was durch
ausschließlicher Verwendung von I-Frames praktisch aufgehoben wird.

Es gibt in ffmpeg eine spetzielle Einstellung (-intra), worauf dann
ffmpeg nur noch Vollbilder (I-Frames oder Intra-Frames) schreibt,
aber ich rate dir davon ab, da manche Player Probleme damit haben
(speziell bei der Navigation im Movie).

Tip:
Versuche mal folgende Einstellmöglichkeiten in ffmeg:
-rc_init_cplx : Dort wird eine Zahl eingegeben, die die
Komplexität der Frameberechnung darstellt.

-qblur : Zahl, die das verwischen der Übergänge nach einer
Größenumrechnung der Frames darstellt.

-qcomp : Zahl, die die Kompression der Bilddaten nach einer
Frameskalierung darstellt.

-hq Schalter, der die "High Quality"-Einstellungen für die Bilddaten
einstellt.

[ - Ändern - Antworten - Zitieren - Direktlink - ]

15.05.2003, 17:46 Uhr

Twister
Posts: 46
Nutzer
Öhm ja, und was kann ich da für Werte angeben ?
Also ich muß gleich mal sagen, daß ich es selten über eine shell betreibe, aber mittlerweile muß ich sagen, daß es dann viel mehr Einstellungsmöglichkeiten gibt. Kannst Du mir da nochmal nen Tip geben, was ich da alles eingeben könnte, damit ich eine gute Qualität herausbekomme. Für eine Beispiel-Befehlszeile währe ich wirklich sehr glücklich.

Gruß

Twister


[ - Antworten - Zitieren - Direktlink - ]

15.05.2003, 19:31 Uhr

pagasos-sigi
Posts:
[Ex-Mitglied]
Twister:

http://ffmpeg.sourceforge.net/ Hier findes du alles Mögliche zu
ffmpeg. Leider gibt es zu viele Einstellungen in ffmpeg. Da kann ich
dir die genauen Einstellungen nicht sagen. Du mußt es selber mal
testen, welche die Besten sind. Du kannst mir natürlich
ein Teil deines Movies schicken, damit ich sehen kann woran es mit
den Fehlerhaten Darstellunen liegt.

CarstenSiegner2@t-online.de

Hier die Einstellungen von ffmpeg 0.4.6


ffmpeg version 0.4.6, Copyright (c) 2000, 2001, 2002 Fabrice Bellard
usage: ffmpeg [[options] -i input_file]... {[options] outfile}...
Hyper fast MPEG1/MPEG4/H263/RV and AC3/MPEG audio encoder

Main options are:
-L show license
-h show help
-formats show available formats, codecs, protocols, ...
-f fmt force format
-i filename input file name
-y overwrite output files
-t duration set the recording time
-title string set the title
-author string set the author
-copyright string set the copyright
-comment string set the comment
-pass n select the pass number (1 or 2)
-passlogfile file select two pass log file name
-b bitrate set video bitrate (in kbit/s)
-r rate set frame rate (in Hz)
-s size set frame size (WxH or abbreviation)
-croptop size set top crop band size (in pixels)
-cropbottom size set bottom crop band size (in pixels)
-cropleft size set left crop band size (in pixels)
-cropright size set right crop band size (in pixels)
-vn disable video
-bt tolerance set video bitrate tolerance (in kbit/s)
-maxrate bitrate set max video bitrate tolerance (in kbit/s)
-minrate bitrate set min video bitrate tolerance (in kbit/s)
-bufsize size set ratecontrol buffere size (in kbit)
-sameq use same video quality as source (implies VBR)
-ab bitrate set audio bitrate (in kbit/s)
-ar rate set audio sampling rate (in Hz)
-ac channels set number of audio channels
-an disable audio

Advanced options are:
-map file:stream set input stream mapping
-em_rate makes img reading happen at nominal frame rate
-g gop_size set the group of picture size
-intra use only intra frames
-qscale q use fixed video quantiser scale (VBR)
-qmin q min video quantiser scale (VBR)
-qmax q max video quantiser scale (VBR)
-mbqmin q min macroblock quantiser scale (VBR)
-mbqmax q max macroblock quantiser scale (VBR)
-qdiff q max difference between the quantiser scale (VBR)
-qblur blur video quantiser scale blur (VBR)
-qcomp compression video quantiser scale compression (VBR)
-rc_init_cplx complexity initial complexity for 1-pass encoding
-b_qfactor factor qp factor between p and b frames
-i_qfactor factor qp factor between p and i frames
-b_qoffset offset qp offset between p and b frames
-i_qoffset offset qp offset between p and i frames
-rc_eq equation
-rc_override qualities for specific intervals Rate control override
-vd device set video grab device
-vcodec codec force video codec ('copy' to copy stream)
-me method set motion estimation method
-dct_algo algo set dct algo
-idct_algo algo set idct algo
-er set error resilience
-ec set error concealment
-bf frames use 'frames' B frames (only MPEG-4)
-hq activate high quality settings
-4mv use four motion vector by macroblock (only MPEG-4)
-part use data partitioning (only MPEG-4)
-bug param workaround not auto detected encoder bugs
-ps size in bits packet size
-strict how strictly to follow the standarts strictness
-debug print specific debug info
-ad device set audio device
-acodec codec force audio codec ('copy' to copy stream)
-deinterlace deinterlace pictures
-benchmark add timings for benchmarking
-hex dump each input packet
-psnr calculate PSNR of compressed frames
-vstats dump video coding statistics to file
-bitexact only use bit exact algorithms (for codec testing)
-vhook module name and parameters insert video processing module


[ Dieser Beitrag wurde von pagasos-sigi am 15.05.2003 editiert. ]

[ - Ändern - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > MorphOS > Probleme mit Poverconverter [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2022 by amiga-news.de - alle Rechte vorbehalten.
.