amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > AROS und Amiga-Emulatoren > PC-Festplatte erst nach Softreset ??? [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

08.09.2003, 15:39 Uhr

Falcon
Posts: 3544
Nutzer
Tach auch,

so, nachdem mein Amithlon nu lüppt, ist mir etwas unschönes
aufgefallen.
Über die 'Setconfig'-Kommandos kann man ja beliebige PC-Platten
und Partitionen auf der Amiga-Seite einbinden. Prima, klappt auch...
Allerdings erst nach einem nochmaligen (Taststur-) Reset.

Beim 1. Start ist das Laufwerk nie da ?!?

Ciao,

Falcon.
--
Che-Hoa Yuin sagt:
Der Amiga kann alles, was man zum Arbeiten braucht...
... was er nicht kann, braucht man auch nicht !!!!!!!

Meine Homepage: http://home.wtal.de/elasticimages

[ - Antworten - Zitieren - Direktlink - ]

08.09.2003, 15:51 Uhr

thomas
Posts: 7668
Nutzer

Vermutlich hast du die Setconfig-Befehle an der falschen Stelle eingefügt. Da ist irgendwo ein "Setconfig resetifchanged" oder so ähnlich. Das muß das letzte sein, deine PC-Festplatten müssen davor stehen, genau wie alle anderen Setconfig-Befehle.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

08.09.2003, 17:24 Uhr

Falcon
Posts: 3544
Nutzer
Hi,

Setconfig Resetifchanged ist der letzte Setconfig-Befehl in
meiner Startup. Trotzdem muß ich resetten, damit die PC-Laufwerke
kommen.

Hier mal ein Auszug meiner Startup-Sequence:

RunEnvCheck >NIL: AMITHLON
If WARN
Path >NIL: C:AmithlonC ADD
Setconfig >NIL: vesa_defaults 0
Setconfig >NIL: clockmax 100
Setconfig >NIL: dosmount C
Setconfig >NIL: asynchronous_io 1
Setconfig >NIL: p96_accell 0xef
Setconfig >NIL: cachesize 16384
Setconfig >NIL: rebootifchanged
AmithlonSetup
Stack 65536
Amithlon_key HaageKey >NIL:
Else
If $MountAmigaHDDs NOT EQ 1
C:MountAmigaHDDs >NIL:
EndIf
Unset $MountAmigaHDDs
EndIf

pciinsmod > ram:PCIINSMOD.TXT

SetPatch QUIET

u.s.w... u.s.w...


Ciao,

Falcon.
Che-Hoa Yuin sagt:
Der Amiga kann alles, was man zum Arbeiten braucht...
... was er nicht kann, braucht man auch nicht !!!!!!!

Meine Homepage: http://home.wtal.de/elasticimages


[ Dieser Beitrag wurde von Falcon am 08.09.2003 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

08.09.2003, 18:10 Uhr

umisef
Posts: 12
Nutzer
Zitat:
Setconfig >NIL: rebootifchanged
AmithlonSetup


Da steckt Dein Problem.

Das Mounten von DOS-Platten (FAT-Platten) ist leider verkorkst, und braucht einen Patch um zu laufen, und *ausserdem* einen Reset (weil Platten eben beim Booten eingebunden werden).

Den Patch laedt bei Dir AmithlonSetup, den Reboot macht setconfig rebootifchanged. Nur kommt der Reboot leider zuerst (also noch bevor der Patch laeuft), und beim zweiten Boot wird dann zwar der Patch eingespielt, aber es gibt keinen Reboot mehr (bis Du's von Hand machst).

Loesung: Pack "AmithlonSetup" *vor* das rebootifchanged, und voila, muesste klappen.

[ - Antworten - Zitieren - Direktlink - ]

09.09.2003, 00:42 Uhr

kadi
Posts: 1498
Nutzer
Macht AmithlonSetup nicht auch einen Reboot?

Ich habe in meiner Startup-sequence "setconfig rebbotifchanged" auskommentiert und es geht trotzdem.

[ - Antworten - Zitieren - Direktlink - ]

09.09.2003, 15:51 Uhr

umisef
Posts: 12
Nutzer
Zitat:
Original von kadi:
Macht AmithlonSetup nicht auch einen Reboot?
Ich habe in meiner Startup-sequence "setconfig rebbotifchanged" auskommentiert und es geht trotzdem.

Nee, "AmithlonSetup" macht keinen Reboot.

Aber Du hast vermutlich spaeter noch das OS3.9 RomUpdate (wie hiess das Programm doch noch?), und *das* rebootet dann. Aber das hat halt nicht jeder....

[ - Antworten - Zitieren - Direktlink - ]

09.09.2003, 20:46 Uhr

kadi
Posts: 1498
Nutzer
Stimmt.

[ - Antworten - Zitieren - Direktlink - ]

09.09.2003, 23:30 Uhr

Falcon
Posts: 3544
Nutzer
Alles klaro, es klappt. Ich habe einfach das AmithlonSetup vor
den letzten Setconfig gesetzt und das war's.

Danke, Ciao,

Falcon.
--
Che-Hoa Yuin sagt:
Der Amiga kann alles, was man zum Arbeiten braucht...
... was er nicht kann, braucht man auch nicht !!!!!!!

Meine Homepage: http://home.wtal.de/elasticimages

[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > AROS und Amiga-Emulatoren > PC-Festplatte erst nach Softreset ??? [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1998-2021 by amiga-news.de - alle Rechte vorbehalten.
.