amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

amiga-news.de Forum > MorphOS > Canon i320 auf MorphOS [ - Suche - Neue Beiträge - Registrieren - Login - ]

-1- [ - Beitrag schreiben - ]

06.10.2003, 18:42 Uhr

analogkid
Posts: 2383
Nutzer
hi,

kann ich irgendwie meinen Canon i320 zusammen mit MorphOS 1.4 benutzen ? Direkte Unterstützung ist wohl erst ab 7.50 drin, aber das muß doch auch so irgendwie gehen. Hat da jemand Erfahrung mit ?
Ich würde nur ungern wegen eines einzigen Druckertreiber 40 EUR löhnen.
--
Gruß,

analogkid

:dance1:

There's a truth in the madness I can't get beyond


Amiga-Forum - Unser Amiga Forum

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 11:09 Uhr

Yvan
Posts: 294
Nutzer
Hi,

geh ich richtig in der Annahme, dass Dein Canon mit dem in 1.4 vorhandenen Turboprint nicht läuft? Bringe meinen HP Deskjet 560C damit auch nicht zum Laufen.

Was meinst Du mit 40 Euro? Was willst Du Dir damit kaufen?


[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 14:50 Uhr

thomas
Posts: 7649
Nutzer
Zitat:
Was meinst Du mit 40 Euro? Was willst Du Dir damit kaufen?

Turboprint natürlich.

Aber drucken unter MorphOS geht doch ohnehin nicht, auch mit den vorhandenen Treibern. Meine Programme kriegen jedenfalls das printer.device nicht geöffnet. Und ich meine irgendwo gelesen zu haben, daß das ein bekannter Fehler ist.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 15:09 Uhr

Yvan
Posts: 294
Nutzer
Zitat:
Original von thomas:


Turboprint natürlich.
....

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/


Eben, dachte ich mir aber. Bei Morphos1.4 ist Turboprint dabei, also wieso sollte er Turboprint kaufen? Kann die Morphos1.4 Version weniger als die andere?
Ich frage übrigens ernsthaft, ich kann nämlich mit dem Morphos 1.4 Turboprint auch nicht drucken .

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 15:34 Uhr

thomas
Posts: 7649
Nutzer

Turboprint besteht aus zwei Teilen: 1. dem Hauptprogramm, ein Ersatz für das printer.device, das auch 24bit-Grafiken drucken kann und viele neue Optionen bietet, wie z.B. verschiedene Farbmischalgorithmen, Poster-Druck, Text-Druck auf Grafikdruckern, Postscript-Druck auf Nicht-PS-Druckern etc. Und 2. aus vielen vielen Druckertreibern.

Seit Version 7.2 (glaube ich) hat sich an dem Hauptprogramm nichts mehr verändert, sondern es sind immer nur neue Druckertreiber dazugekommen. Deshalb lohnt sich ein Update von 7.x auf 7.5 auch nur, wenn der eigene Drucker in der älteren Version nicht unterstützt wird.

Da hier aber nicht geklärt ist, ob es nur am fehlenden Treiber oder aber am System an sich hapert, würde ich von einem Kauf erstmal absehen (allerdings könnte die 68K/PowerUP-Version von Turboprint allein schon Abhilfe schaffen, gegenüber der MorphOS-Version).

Nun ist "ich kann nicht drucken" natürlich auch keine besonders nützliche Fehlerbeschreibung. Wie äußert sich das ? Findest du keinen passenden Druckertreiber ? Funktioniert das Drucken, aber der Drucker druckt nur Schrott ? Sagt das Programm, es würde gedruckt, aber es kommt nichts raus ? Sagt das Programm, es könnte den Drucker nicht ansprechen ?

Ein Update der Treiber lohnt sich nur in dem Fall, "es wird gedruckt, aber nur Schrott", weil das bedeutet, daß alles funktioniert, nur kein passender Treiber vorhanden ist. In allen anderen Fällen muß man erstmal nach der Ursache suchen und ggf. das Hauptprogramm anpassen (wie gesagt, evtl. könnte hier das originale 68k-Turboprint schon helfen. Wenn es also wirklich dringend ist, mit dem Drucken, dann lohnt sich der Kauf von TP vielleicht doch).

Ich weiß auch nicht, ob es problemlos möglich ist, das Original-Turboprint und die Morphos-Version parallel zu betreiben. Zumindest könnte es evtl. Probleme geben, wenn man die Einstellungen mal mit dem Turboprint-Programm und mal mit den Druckereinstellungen aus dem Morphos-Menü bearbeitet.

Gruß Thomas
--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 15:45 Uhr

Yvan
Posts: 294
Nutzer
Ops jetzt aufpassen, der Thread ist von Analogkid nicht von mir. Er fragt ja nur ob er mit seinem Drucker wohl drucken kann.

Mein Problem habe ich schon in der beta2mailing-liste durchgeackert und genauer beschrieben, das will ich hier eigentlich gar nicht wiederholen. Ich war nur ein bisschen erstaunt als ich hier rauszulesen glaubte (was auch stimmt), dass er Turboprint kaufen will mit Morphos 1.4.

Aber diesen Punkt hast Du ja genauer dargelegt. Ich dachte auf Morphos 1.4 sei eigentlich alles dabei was zu Turboprint gehört deshalb kam ich gar nicht auf die Idee mein eigenes Turboprint welches auf meinem A1200 installiert ist auf meinem Peggy auszuprobieren.

Aber so wie ich das nun sehe würde es sich vermutlich für mich mal lohnen das printer.device zumindest mal rüberzukopieren.

Falls Du Dir mein Problem genauer ansehen willst:

http://www.morphzone.org/modules/newbb/viewtopic.php?topic_id=862&forum=16





[ Dieser Beitrag wurde von Yvan am 07.10.2003 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 16:16 Uhr

Brunadi
Posts: 1365
Nutzer
Hallo Thomas

Jubiläum ! ! ! ;) ;)

Gruß Brunadi :rotate:
--
Die meisten Computerfehler sitzen vor dem Bildschirm..

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 16:37 Uhr

thomas
Posts: 7649
Nutzer
Zitat:
Original von Brunadi:
Hallo Thomas

Jubiläum ! ! ! ;) ;)

Gruß Brunadi :rotate:
--
Die meisten Computerfehler sitzen vor dem Bildschirm..



Das hat mich doch jetzt ehrlich in eine Zwickmühle gebracht, denn sobald ich antworte, ist das Jubiläum vorbei, ich kann euch also gar nicht an meiner Feier teilhaben lassen...

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 16:47 Uhr

Brunadi
Posts: 1365
Nutzer
Zitat:
Original von thomas:



Das hat mich doch jetzt ehrlich in eine Zwickmühle gebracht, denn sobald ich antworte, ist das Jubiläum vorbei, ich kann euch also gar nicht an meiner Feier teilhaben lassen...

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/


Dann werde ich wohl beim nächsten Jubiläum - 1 gratulieren.

Gruß Brunadi :rotate:
--
Die meisten Computerfehler sitzen vor dem Bildschirm..

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 16:47 Uhr

thomas
Posts: 7649
Nutzer
Zitat:
Original von Yvan:

Falls Du Dir mein Problem genauer ansehen willst:

http://www.morphzone.org/modules/newbb/viewtopic.php?topic_id=862&forum=16



Naja, so ergiebig ist der Thread auch nicht. (Ich frage mich auch, warum sich da zwei deutsche auf englisch unterhalten :rotate: ).

Such mal bei MorphZone nach "drucken". Da siehst du, daß andere auch Probleme damit haben. Vor allem der Monolog von AC-Eule ist recht interressant. Er beschreibt ungefähr das gleiche Problem, das du hast.


@analogkid: der Thread von Yvan könnte einen Hinweis geben: da steht nämlich sinngemäß "probier mal den generischen HP DeskJet-Treiber". Das könnte man umformulieren in "probier mal den generischen Canon-Treiber" (wenn so einer dabei ist).

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 21:19 Uhr

analogkid
Posts: 2383
Nutzer
Zitat:
Original von thomas:

der Thread von Yvan könnte einen Hinweis geben: da steht nämlich sinngemäß "probier mal den generischen HP DeskJet-Treiber". Das könnte man umformulieren in "probier mal den generischen Canon-Treiber" (wenn so einer dabei ist).

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/



ich hab alle Canon-Treiber durch, keine Reaktion vom Drucker.

ich hab mal an Irseesoft deswegen geschrieben und folgende Antwort bekommen:


Sehr geehrter Herr Schmitz,

das in MorphOS integrierte Drucksystem stammt zwar von TurboPrint ab,
jedoch sind die Treiber nicht zueinander kompatibel.


Ich deute das so, dass mir Turboprint 7.50 auch nicht weitergeholfen hätte... :(
--
Gruß,

analogkid

:dance1:

There's a truth in the madness I can't get beyond


Amiga-Forum - Unser Amiga Forum

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 22:42 Uhr

Eule
Posts: 1607
Nutzer
Ich hab bei mir einen HP-Drucker erfolgreich am Laufen, sowohl üner
den paralell Port als auch über das usbparallel.device.

Genau Tipps dazu gibts hier:

http://www.amiga-news.de/forum/thread.php3?id=6931&BoardID=4


Erst mal sollte man Testen ob 'Ausdruck in Datei' funktioniert.
Wenn diese Datei auch wirklich gedruckt werden kann ( mit Amig, PC
oder LINUX direkt auf den Paralellport ausgeben ) dann wisst ihr, dass
Turboprint geht.

Und hier für USB Drucker:

http://www.amiga-news.de/forum/thread.php3?id=7630&BoardID=4

[ - Antworten - Zitieren - Direktlink - ]

07.10.2003, 23:13 Uhr

Eule
Posts: 1607
Nutzer
Ach ja vielleich sollte icherwähnen dass man auf jeden fall das
eingebaute TurboPrint nehmen soll. Alle Assign auf ein eventuell
doppelt vorhandenen System solten entfernt werden.

cu Eule

[ - Antworten - Zitieren - Direktlink - ]

08.10.2003, 08:37 Uhr

Yvan
Posts: 294
Nutzer
Hallo Thomas und Eule,

vielen Dank, ich schau mir eure Links und Hiweise mal genauer an.

Ach ja Thomas, wen meintest Du denn mit dem zweiten Deutschen? Kann ja gar nicht seit, ausser tokai und mir hat ja niemand geschrieben. Wenn Tokai Deutscher ist, dann kann ja gar niemand in dem Thread sonst noch Deutscher sein?

[ - Antworten - Zitieren - Direktlink - ]

21.10.2003, 08:45 Uhr

Yvan
Posts: 294
Nutzer
Ich hab jetzt eine Möglichkeit gefunden, naja ein Trick. Ich drucke in eine Datei namens turbo.prt (Name Wurst) und dann in einer Shell gebe ich 'copy turbo.prt PAR:' ein und es druckt wunderbar (ausser die letzte Seite, da hänge ich einfach eine Dummy Seite an).

'copy turbo.prt PRT:' geht nicht, scheint wirklich ein printer.device Problemz zu sein.

Okay ist nicht die schönste Lösung, aber bis die das ganze gefixt haben kann ich damit leben.
--
Eigenschaften
------------------------------------
engstirnig, schlechtes Sprachverständnis

[ - Antworten - Zitieren - Direktlink - ]

21.10.2003, 11:51 Uhr

platon42
Posts: 400
[Ex-Mitglied]
Zitat:
Original von Yvan:
Ich hab jetzt eine Möglichkeit gefunden, naja ein Trick. Ich drucke in eine Datei namens turbo.prt (Name Wurst) und dann in einer Shell gebe ich 'copy turbo.prt PAR:' ein und es druckt wunderbar (ausser die letzte Seite, da hänge ich einfach eine Dummy Seite an).

'copy turbo.prt PRT:' geht nicht, scheint wirklich ein printer.device Problemz zu sein.


Natuerlich kannst Du die mit TurboPrint erzeugte Datei nicht an PRT: schicken -- hinter PRT: steckt ja TurboPrint, dass als Eingabe eine Text-Datei erwartet und an den Drucker schicken will. Uebrigens sind viele Drucker inzwischen nicht mehr in der Lage, Text pur zu drucken und es muss deshalb in TurboPrint "Text als Grafik" aktiviert werden. Wegen der letzten Seite: Wenn Dein Drucker einen USB Anschluss hat, dann geh ueber USB, denn das usbparallel.device hat nicht das Problem mit dem letzten Puffer, der verloren geht.


--
--
Best Regards

Chris Hodges

[ - Antworten - Zitieren - Direktlink - ]

21.10.2003, 12:20 Uhr

Yvan
Posts: 294
Nutzer
Ach so, dann ist klar dass es mit prt: nicht geht. Nein Du, ist ein altes Ding und hat nur parallel Port Anschluss, kann aber auch Text direkt drucken.
--
Eigenschaften
------------------------------------
engstirnig, schlechtes Sprachverständnis

[ - Antworten - Zitieren - Direktlink - ]

21.10.2003, 13:43 Uhr

thomas
Posts: 7649
Nutzer
Zitat:
Original von Yvan:
Ach ja Thomas, wen meintest Du denn mit dem zweiten Deutschen? Kann ja gar nicht seit, ausser tokai und mir hat ja niemand geschrieben. Wenn Tokai Deutscher ist, dann kann ja gar niemand in dem Thread sonst noch Deutscher sein?


Und du ? Sprichst du nur aus spaß deutsch ?

Zitat:
Ich hab jetzt eine Möglichkeit gefunden, naja ein Trick. Ich drucke in eine Datei namens turbo.prt (Name Wurst) und dann in einer Shell gebe ich 'copy turbo.prt PAR:' ein und es druckt wunderbar (ausser die letzte Seite, da hänge ich einfach eine Dummy Seite an).

Meinst du, du stellst in Turboprint ein, daß du in eine Datei druckst, oder in dem Programm, aus dem du druckst ?

Wenn du das in Turboprint machst, dann sag ihm doch direkt, daß er in die Datei PAR: drucken soll. Den Seitenvorschub nach der letzten Seite kannst du in Turboprint einstellen.

Gruß Thomas

--
Email: thomas-rapp@web.de
Home: home.t-online.de/home/thomas-rapp/

[ - Antworten - Zitieren - Direktlink - ]

21.10.2003, 15:36 Uhr

Yvan
Posts: 294
Nutzer
@Thomas
>Und du ? Sprichst du nur aus spaß deutsch ?

Nicht alles was Deutsch spricht ist Deutsch, bin Schweizer.

>Meinst du, du stellst in Turboprint ein, daß du in eine Datei druckst,
>oder in dem Programm, aus dem du druckst ?

In Turboprint

>Wenn du das in Turboprint machst, dann sag ihm doch direkt, daß er in
>die Datei PAR: drucken soll. Den Seitenvorschub nach der letzten Seite
>kannst du in Turboprint einstellen.

Einfache Ideen sind oft einfach genial. Muss ich ausprobieren, sollte gehen. Danke


[ Dieser Beitrag wurde von Yvan am 21.10.2003 editiert. ]

[ Dieser Beitrag wurde von Yvan am 21.10.2003 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

21.10.2003, 21:53 Uhr

Eule
Posts: 1607
Nutzer
Mit dem Drucken einer Datei kann man zumindest ausprobieren dass der
Druckertreiber ( also das Programm was die Zeichen für den Drucker
aufbereitet ) funktioniert.

Beim paralell.device hab ich so meine Zweifel, dass es 100% richtig
ist. Jedenfalls funktioniert ein Canondrucker für den es Treiber gibt
nicht aber ein HP Drucker funktioniert dafür richtig. Mir kommt es
einfach so vor als ob mal der Handshake auf der paralellen
Schnittstelle nicht so ganz korrekt ist. Überprüfen könnnte ich es nur
wenn ich den Drucker z.B. an die serielle Schnittstelle hänge, die
scheint aber für das Debug reserviert zu sein. Zumindfest kann ich
nichts einstellen was eine vernünftige Geschwindigkeit bei einer
seriellen Schnittstelle garantieren würde.

Und bevor ich mir Hardware zum Testen an einem alten Drucker kaufe,
kauf ich mir lieber einen TCP/IP Druckerserver, da haben alle zuhause
was davon.

cu Eule

[ Dieser Beitrag wurde von Eule am 21.10.2003 editiert. ]

[ - Antworten - Zitieren - Direktlink - ]

22.10.2003, 12:44 Uhr

Yvan
Posts: 294
Nutzer
@Eule
Mit "setenv boot-file boot.img ramdebug" in der SmartFirmware natürlich, leitest Du den Debugoutput in den Arbeitsspeicher um, Default ist serielle Schnittstelle. Dann solltest Du die serielle Schnittstelle auch für anderes brauchen können.

Info hab ich von hier:

http://www.morphos-news.de/beta2help/qstart_de.html


[ - Antworten - Zitieren - Direktlink - ]

22.10.2003, 18:39 Uhr

Peggy
Posts:
[Ex-Mitglied]
also ich konnte auch erst nicht unter Morphos1.4 drucken mit meinen Epson 880 und Epson PhotoEX (A3)

dann hab ich das vorherige Assign von Turboprint entfernt und
jetzt druck ich wunderbar.

vielleicht hilft es Dir auch weiter
:D

Grus Peggy

Pegasos G3/Morphos1.4

:shoot3:

[ - Ändern - Antworten - Zitieren - Direktlink - ]

23.10.2003, 08:38 Uhr

Yvan
Posts: 294
Nutzer
Danke Peggy, aber ich hatte nie Turboprint auf dem Peggy installiert, als ich hörte, dass es in 1.4 dabei ist beschloss ich zu warten auf 1.4. Das heisst, keine assigns welche entfernt werden mussten und so.

PS:
Ist ein bisschen verwirrend, dass Du gleich heisst wie mein Rechner.


[ - Antworten - Zitieren - Direktlink - ]


-1- [ - Beitrag schreiben - ]


amiga-news.de Forum > MorphOS > Canon i320 auf MorphOS [ - Suche - Neue Beiträge - Registrieren - Login - ]


.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2019 by amiga-news.de - alle Rechte vorbehalten.
.