amiga-news ENGLISH VERSION
.
Links| Forum| Kommentare| News melden
.
Chat| Umfragen| Newsticker| Archiv
.

[Login] [Registrieren] [Passwort vergessen?]

< Nächste MeldungVorige Meldung >
04.Okt.2004



AmigaOne: Probleme beim Zusammenspiel von Onboard-IDE und Ethernet
Stéphane Guillard, der Entwickler der IDE-DMA-Treiber für AmigaOS 4, erläutert in einem Thread auf ANN, dass der Onboard-IDE-Kontroller der bisher produzierten AmigaOne-Motherboards nur dann im DMA-Modus betrieben werden kann, wenn nicht gleichzeitig noch ein Ethernet-Treiber genutzt wird.

Laut Guillard tritt das Problem nur in der Kombination "Onboard-IDE-Controller und beliebiger Ethernet-Chip" auf. Solange die Netzwerkverbindung nicht genutzt wird oder ein anderer IDE-Controller Verwendung findet, funktioniert das Zusammenspiel aller DMA-Quellen (IDE, USB, Soundkarte etc.) einwandfrei.

Um dem Problem vorerst aus dem Weg zu gehen, kann ein PCI-IDE-Controller mit Silicon Image 680 Chipsatz (UDMA133) verwendet werden. Der entsprechende Treiber steht Betatestern bereits zur Verfügung, da besagter Chipsatz auch auf dem angekündigten "Micro-A1 I" Verwendung findet. Ein Screenshot von SCSISpeed zeigt Benchmarks der allerersten Treiber-Version im UDMA-Modus:

Screenshot von SCSISpeed

Als Ursache des Problems nennt Guillard die VIA-Southbridge des Motherboards, er spricht von "falscher Verdrahtung" derselben bzw. einem "Design-Fehler". Hersteller Eyetech hat zwar bisher noch keine öffentliche Stellungnahme abgegeben, erklärt jedoch in einem nur AmigaOne-Besitzern zugänglichen Forum auf amigaworld.net, dass lückenhafte Dokumentation und nicht existenter Support eine korrekte Initialisierung der Southbridge erheblich erschweren. Man arbeite zwar bereits an einer Lösung - einen (Hardware-) Patch, der auf allen Motherboards funktioniert und der sich mit vertretbarem Aufwand implementieren ließe, könne man jedoch noch nicht vorweisen. Registrierte AmigaOne-Besitzer mit Zugang zum entsprechenden Forum auf amigaworld.net finden hier das komplette Statement von Alan Redhouse (Eyetech).

Die angekündigten "Micro-A1" Motherboards sind von diesem Problem nicht betroffen, da beim "Micro-A1 I" ein anderer IDE-Controller Verwendung findet und der "Micro-A1 C" bereits mit einem Workaround ausgestattet ist. (cg)

[Meldung: 04. Okt. 2004, 22:19] [Kommentare: 181 - 07. Okt. 2004, 01:23]
[Per E-Mail versenden]  [Druck-Version]  [ASCII-Version]
< Nächste MeldungVorige Meldung >

.
Impressum | Datenschutzerklärung | Netiquette | Werbung | Kontakt
Copyright © 1997-2018 by amiga-news.de - alle Rechte vorbehalten.
.